Drag n Drop not working


Drag and dropping files over the WIP does not work at least not always. Is this expected at this point?

When drag dropping from the desktop or windows explorer D&D works. However in my goto file manager Freecommander the D7D works for V5 but not the WIP.

So something is different in how the WIP handles a D&D from how V5 does that.

For testing you could run the portable (no install) version of freecommander to be found here:


What are you dragging and dropping? Are you running the Rhino WIP as an administrator or with elevated privileges? This is known not to work…

Hi Dale,

A .3dm file that when drag droped from the same location ( my filemanager; FreeCommander) works in V5 but not for the WIP

No it’s a “regular run” afaik: as a test if I run the WIP as administrator, indeed I cannot drag and drop from windows explorer.

When I drag drop running in normal mode, I can DragDrop from windows explorer but not from my filemanager.
I do get a [+] icon at the cursor but after that nothing happens.
For a quick test I post the .zip file with the portable (no install) version of free commander.
FreeCommanderXE-32-public_portable.zip (7.5 MB)

Just unzip it and run FreeCommander.exe
Navigate to a 3dm file (defaults to desktop) and drag drop it over a WIP instance

For V5 this works for me, but not for the WIP


Well I am able to repeat what you are report. I have no idea how to fix, unfortunately…


1 Like

I ran this through the debug process and found that Rhino is getting a files dropped message from Windows but Windows is reporting 0 files and a “ERROR_INVALID_HANDLE 6 (0x6) The handle is invalid” Windows error. I’m not sure what can be done about this, it appears that the data being provided by FreeCommander is not formatted in a way that is compatible with the current Microsoft tools. I would suggest contacting the FreeCommander people to see if this is a known problem.

Hi John,

Thanks for investigating. I’ll try to pass this to the freecommander support.

Yet V5 has no problem opening the file, so the WIP is using other code to parse a drag n drop?


No it’s the identical code…

If so, how come V5 does and the WIP doesn’t catches the drag drop?


Well, if we knew this…

Hi Dale and @JohnM

Thanks for your efforts.
I emailed the developer of the filemanager and pointed him to this issue.
As I decided it was a good opportunity to donate to the developer, I found the donation gave access to his 64bit version.

@ Marek Jasinski if you are reading along: The 64bit version did not exhibit the malfunctioning and worked as expected.

So I leave it be thanks


Run Rhino without administrator privilege. It was the solution

1 Like