Drag-drop bitmap from Explorer to surface suddenly fails

unhandled

#1

All of a sudden I can no longer drag drop a bitmap from explorer onto a Rhino surface and see it in render mode. This always worked perfectly in the past. Suddenly it fails to work.

Any solutions? Thanks


(Pascal Golay) #2

Hi Matt - yeah, it should work as far as I can see … Maybe close and reopen Rhino and try again?

-Pascal


#3

I tried that, with no luck. It appears that when I drag the image to Rhino workspace and hover over a surface it does not recognize the object and thinks I am dropping into empty space, so I get a 4 option dialog box (picture frame, wallpaper, etc.)

As mentioned, this never happened before.

Thanks,

Matt


(Pascal Golay) #4

Hi Matt - Hmm - I’ll see what I can find out - for now, I guess the indirect method of choosing Texture Palette and then drag from the textures onto the object - btw does that drag and drop work? From the texture panel to an object?

-Pascal


(John Brock) #5

Is it just that specific bitmap or do all bitmaps; even ones that worked before, refuse to drag/drop?


(Pascal Golay) #6

Matt, do you have any plug-ins loading (non-default ones) If so, what are they? Is Rhino Render the current renderer?

-Pascal


#7

All bitmaps refuse to drag-drop now and, no, I cannot drag from texture palette either. Simply does not register the receiving object with mouse hover. Used to highlight the receiving surface I believe. I have rebooted and restarted Rhino.


(Pascal Golay) #8

From what the developer tells me the most likely thing is that there’s a plug-in getting into the queue for handling drag and drop before the Rhino RDK, which handles what you are trying to do. But… if so, what plug-in - are you running any that are not standard with Rhino?

-Pascal


#9

Well, I have Maxwell Render for Rhino and I recently switched to that renderer, then switched back to the default Rhino Render engine. I also run grasshopper. Other plugins as well but nothing I loaded myself recently other than a Flamingo trial.


(Pascal Golay) #10

OK- thanks - right now, I blame Flamingo only because it looks like maybe being the last thing you added. Let’s try disabling that in Options > Plug-ins page and then restart Rhino. Any different?

-Pascal


#11

Unfortunately no change. When dragging a jpg to Rhino workspace I see the + symbol and am able to select texture palette for a destination, but cannot directly drop to a surface. Still no luck dragging from texture palette either.


(Pascal Golay) #12

Hi Matt - lets disable all the other plug-ins that show up in Options >Plug-ins page with the view filtered for ‘plug-ins that do not ship with Rhino’ and restart Rhino… any luck at all?

-Pascal


#13

Tried that (unchecking the plugins not shipped with Rhino then restarting). No luck. Nothing happens when hovering over an object. I keep getting this dialog which I never got before.


(Pascal Golay) #14

@andy, @JohnM - any ideas here?

-Pascal


#15

Hi - I just tried drag-drop with Rhino WIP (Rhino 6 beta) and it works just fine. Weird. Something wrong specifically with my Rhino 5.

Matt


(John Morse) #16

What happens if you chose the “Texture Palette” option and click OK?


(John Morse) #17

Make sure no objects are selected then attempt to drag the bitmap over an object, does the object highlight when you mouse over it?


#18

No, the object does not highlight when I drag bitmap over it. I get plus symbol and dialog box as if dragging to empty space. If I select Texture Palette from that the image goes there, however I cannot drag that image from texture palette over image either. The issue is with the mouse-over on rhino object. Note that this problem does not exist with Rhino 6 WIP, only Rhino 5 and only as of recently (worked fine before).

Thanks for any insights.


#19

Hi! I have the same problem!
I can’t drag and drop (images or files like 3dm, dwg, stl…) in rhino 5.
Before I could made it, but now I can’t…
In rhino 6 I can drag and drop correctly.