Drag deselect vertices doesn't work

Is this a bug?

can’t deselect the upper row of vertices to scale only the bottom ones

Thank you!


Hi Hannes - can you post the objects?


@pascal this is drag selection. It seems only to add objects, but you cannot deselect objects or points once selected. you know Ctrl+Shift Select

Maybe Rhino can be implemented this feature. Would help a lot.

Ah, yes - right, that does not work.


Press and hold Ctrl when windowing to remove selected objects from the selection.
Ctrl+Shift to add, Ctrl to remove.

@John_Brock sorry, Ctrl does not work. :frowning:

I just tried it here to make sure I had the details right.
It works fine for me.
Are you pressing and holding Ctrl when you drag your deselection window over the selected items?

1 Like

Yes I have tried both, does not work. so it’s Ctrl-Shift drag select. and in this mode I am only able to add more but not to deselect.

Clearly something is different then…
In Options > Mouse, is Method set to Combo?
In Selecting, are all 4 items checked?

I checked the forth one now I am able to deselect but it will deselect whole surface groups. I just wanted to drag deselect points. It is still not possible. :frowning:

Thanks John

You may have to use the Selection Filter to make all of that work as you want.

Here’s a Mesh with Points turned on and selected (SelPts):

Here I have pressed Ctrl and dragged a selection window through the points to remove them:

1 Like

Made you a video to explain things

It is subobject selection that does not work that way, as far as I understand the question, is that right @hannesgrebin ?


@pascal this is true. It is the subobject selection. It would be awesome to add this feature to Rhino. For easy selection and deselection on the ongoing prototype if I want to alter the object.