Drag and drop on blocks

Hi

i’m currently working on drag and drop functionality in Rhino 5 and 6.
Now i encountered a problem in Rhino 6 which does not exist in Rhino 5.
The drop on object does not work correctly if i want to drop on more than one blocks. To reproduce this behaviour put two or more blocks in a scene, try to drop a material on one block and then on the other. In Rhino 5 it’s possible, in Rhino 6 not.

Any hints about that?
Thanks

@JohnM, can you look into this?

This is a problem in the display, the mouse over code asks the display for which object is under the mouse and uses it. This is from the display developer: “Blocks now have their own draw list… which means every object ID starts with 0 and increments from there… and right now there is no way to distinguish between Block 1 object N and Block 2 object N”

Thanks @JohnM. As this is a regression, I’ve logged the issue.

https://mcneel.myjetbrains.com/youtrack/issue/RH-54102

– Dale

Hi @dale
during my search about this problem, i found another discussion and also a issue which could be related: https://mcneel.myjetbrains.com/youtrack/issue/RH-47337
I think this is the same issue about the selection map for block instances. The only difference between those issues are that RH-47337 is “only” logged as bug, not as regression.

For us it has an huge impact, because we are working a lot with block instances.
We would really appreciate it if you can prioritize this issue.

Thanks

@dsw, I’ve elevated this issue. Hopefully we can squeeze a fix into a SR.

– Dale

1 Like