Drafthorse - Layout Management tools for Grasshopper

Very cool, thank you! Looking forward to testing @jokamm !

Hey @jokamm ! Thank you again for the plugin, I think I will use it in my work now. It is the best way to work with title block in grasshopper right now. It would be great to have “hide objects in detail” command from rhino as well, some dimensions objects on one detail are too large to show them, while I need these dimensions in the other detail window.

Also, when deconstructing a detail, it does not give a proper bb rectangle.

@dfytz1 Do you mean a command in grasshopper? There is already a “hide objects in detail” command (_HideInDetail) in Rhino 7, not to mention _HideLayersInDetail, as well as all of the layer-specific controls for hide/show states available in Rhino 8 - see what @michaelvollrath is up to here: R8 - BUG - Grasshopper Content - Detail Visibility Not Retained. I am hoping/planning to develop some grasshopper components that make this easier to manage as well, but that’s a ways off for now.

2 Likes

Yess, I know about (_HideInDetail), and that would be so good to have in grasshopper. So nice that you’re answering all the questions, thank you!

One more thing:


I cannot install latest version, it does not show up in the package manager, it cannot be downloaded from f4r, and install button on f4r does not help.

Hi @dfytz1 - I built 0.4.0 and later against the latest service release of Rhino, so if you’re not updated it won’t show up in the package manager. I’m spending most of my efforts working on a version for rhino 8 right now, but I’ll work on RH7 compatible development where possible.

3 Likes

Hi, your plugin seems interesting and I wanted to try it ouy. Unfortunatelly, after multiple installations, it still doesn’t load. It’s not present among other GH plugins and the command prompt shows me this message when I start the Grasshopper. It’s not something critical for me, but maybe somebody else is facing the same issue, so I’m just letting you know.

An error occured during GHA assembly loading:
  Path: ***\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\DraftHorse\0.4.1\DraftHorse.gha
  Exception System.TypeLoadException: 
  Message: Could not load type 'CurveComponents.Make2DViewParameter' from assembly 'CurveComponents, Version=8.2.23333.9481, Culture=neutral, PublicKeyToken=dda4f5ec2cd80803'.

Hi, it yet does not work with Rhino 8 right?

An error occured during GHA assembly loading:
Path: C:\Users\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\DraftHorse\0.4.1\DraftHorse.gha
Exception System.TypeLoadException:
Message: Could not load type ‘CurveComponents.Make2DViewParameter’ from assembly ‘CurveComponents, Version=8.0.23304.9001, Culture=neutral, PublicKeyToken=dda4f5ec2cd80803’.

He hasn’t officially launched it for R8 yet but if you set your Package Manager to Service Release Candidates I believe he pushed a version there that works with R8.

EDIT:

Nevermind, I see that that is the version you are running

@ShynnSup I don’t think it works yet in R8, no

I do want to automate the creation of layouts and I am thinking to use Drafthorse, the only issue it is that I don’t understand how I can scale the Details of the layouts to fit my geometries.

I do created some rectangles around the parts that I need to generate a separate layout for each red rectangle using the A4L layout from the Rhino file as template.

DraftHorse_generate_Layouts_from_Templates.3dm (423.2 KB)

Looks like the CopyLayout component can be improved a little bit. I do need to always copy the same layout template and looks like I can’t define this directly but only using a value from a ValueList that it is not updating as I do change between Rhino files and the ValueList it is picking the first layout from document instead the one I do want to use.

How I can define a detail size when creating a new Layout? Looks like I can control the size of the Layout (paper size) but I can’t find a way to control the size of the detail generated? The Detail created by default (black rectangle) it is too small for my needs, I do need to extend the detail size to the red rectangle.

Also, how I can automatically find the GUIDs of the Details from generated Layouts?

Hi @Cumberland - thanks for trying out Drafthorse. This component is a bit confusing - in Rhino 7 layout names are not unique, so as a workaround I am using the layout index -its position in the Layout Table. To get this index, use the “get layout index” component.

In Rhino 8, Grasshopper has implemented a lot more native Rhino objects, including layouts, so the Rhino 8 version of Drafthorse will use layout objects instead. There are a few bits of the RH8 version that are still getting worked out, so right now it’s only available as a beta (see Drafthorse - Layout Management tools for Grasshopper - #20 by jokamm)
DH_ReferenceLayouts_Example.gh (21.2 KB)

2 Likes

Thanks for the feedback @Cumberland - I set the margin to a default, but that would not be difficult to expose as an input. For generating and modifying details on a page, I made the New Detail component. You can customize whatever layouts you want to generate on a page this way.


DH_NewDetails_Example.gh (22.3 KB)

For getting the GUIDs of a detail to modify it, use the “deconstruct layout” component, as in this example:

DH_NewLayout_Example.gh (23.3 KB)

3 Likes

Thank you for sharing! I am running into an error message with the "new detail’ and “edit detail” components.

“Solution exception:An item with the same key has already been added.”

I’m curious if anyone else has run into this issue. A colleague of mine can use the same rhino file and same script but doesn’t get the errors. I have tried uninstalling & reinstalling with no luck.

Any help would be greatly appreciated! Thanks!

@nikkiw can you give me some more information about your setup? Are you on Rhino 7 or 8? Which version of Drafthorse are you using? Please send more context for your error - if you can reproduce and post the error in a simplified example (.3dm + .gh) I’ll have a better chance of figuring out the issue. Thanks!

Drafthorse for Rhino 8 is now available on yak, food4rhino, and github! For comments/questions issues on the rhino 8 fork of this project, please post to this thread: Drafthorse for Rhino 8

Hi, I install and open the example file in both rhino 7 and 8, when i click make, it frozen then crash rhino

Hi @baoqtrinh97 - sorry it’s not working for you! Can you tell me more about your crash? Which example file are you using, and just to check, which version of Rhino and Drafthorse are you using?
Thanks, jo