DraftAngleAnalysis and transparency in Rhino6 not working

I know what he’s referring to… When looking up from underneath the picture object, the CPs of the analyzed surface are blocked by the picture…However, if you happen to be looking up through part of the analyzed surface, then CPs above the picture are then visible… Clearly the “Picture Frame” object behavior is causing this, since I don’t see the problem with just a texture mapped plane with SetObjectDisplayMode=Rendered…which is basically all _Picture is.

I’m looking at this now…will let you know when it’s fixed.

Thanks,
-Jeff

Yes…working on it now… However, if it’s really a show-stopper for you, a workaround is to simply stop using the _Picture command, and just draw a plane…set it to always “Rendered” using the SetObjectDisplayMode command, then assign a material to the plane using the desired texture you would have used as the _Picture command.

There is something very specific about how a _Picture object is being dealt with that is impacting the depth buffer tests at the wrong time… but as I mentioned, if you simply use a texture mapped plane and SetObjectDisplayMode=Rendered (which is pretty much what _Picture does), then the problem goes away.

So either use the workaround for now, or wait a day or so to pick up SR13 WIP.

Thanks,
-Jeff

Hi Jeff,

Thanks for your help in the mean time.

When I add a normal plane and set the texture, like you mentioned, the problem persists in the same way.
So that is not an option for me.

I’m hoping on a definitive solution, thanks.

Daan

.

Hmmm…well then maybe we’re talking about two different issues… The best way to make sure we’re looking at the exact same thing is to provide a 3dm file that demonstrates the problem, along with a screenshot that shows us what you’re seeing.

So to clarify the two problems you’re experiencing:

  1. Working with transparent materials, an unselected mesh object using DraftAngleAnalysis is rendered opaque, but selecting the mesh object renders it fine.
  2. Working with a Patch surface using DraftAngleAnalysis, when the surface is above a _Picture object, and the surface’s control points are ON, the control points are not visible when viewing them from underneath the _Picture object (i.e. you’re trying to look through the _Picture object, at the surface’s control points).

I can easily reproduce 1 and will fix that…but #2 seems to be questionable now… Is transparency involved in #2 as well? Please provide a simple example that is saved with the camera positioned correctly and display mode set, along with an explanation on which surface needs to have DraftAngleAnalysis…so that all I need to do is load the file, select that surface, run DraftAngleAnalysis, and turn its control points ON to see the problem (i.e. no view manipulation required)…as well as a screenshot of the problem so that we can see what you’re seeing.

Thanks,
-Jeff

Wish: Add the ability to pick the direction of the draft angle after it’s activated. Or at least make it change automaticaly when the Cplane is changed. Or even better, add a dedicated button “Direction” in the Draft angle window, so that clicking it will evoke a few options in the command line, such like:

  1. Pick direction (picking 2 points in the 3d space, no matter how the active Cplane is oriented in the 3d space).
  2. Normal to World Z (always vertical, no matter how the active Cplane is oriented in the 3d space).
  3. Normal to the active Cplane (automatically changes the draft angle direction upon activating a different Cplane).
  4. Pick fixed Cplane (allows you to select which Cplane will be used for projection so that the draft angle will be permanent in this direction, even if the active Cplane is different).

Currently, when the Cplane is being repositioned (or when another Cplane is activated), the draft angle direction will not change accordingly. It will still show the old draft angle direction, even if the “Remove objects” button is pressed to remove the object from the draft angle analysis and then the “Add objects” is pressed to add the same object again. The only way to make it work now is to completely close the “Draft angle” window and then run the command again. However, that’s a problem when dealing with multiple objects, because they must be also selected every time the user does this change of direction for the draft angle.