DraftAngleAnalysis and transparency in Rhino6 not working

Hi everyone,

Thanks for the new release of Rhino.

I’m a heavy user of the _DraftAngleAnalysis command with transparency.
In the older versions, transparency worked. In Rhino6 it doesn’t, wich is a big problem.

Does anyone know how to get transparency in Rhino6 with the _DraftAngleAnalysis command in Rendering mode? Or is it a bug?


For the clearity:
I’m using a surface with transparency set in the material settings.
Everything behind it is not showing.

Works just fine in Rhino5, but not in Rhino 6.

Hi Daan - I see this, thanks.


1 Like

Hi Pascal,

Is there any sight on a solution?
As mentioned I’m a heavy user of the _DraftAngleAnalysis command with transparency.
I Can’t us Rhino 6 right now, it’s a pity.

Hoping on a solution,

Greetings, Daan

Hi Daan - sorry, as far as I can see the item is open but not yet fixed. I added a comment for the developer,



Pascal, thanks for your help for now but…

It’s really a shame that it takes so long, 4 months now. I payed a lot of money for the upgrade and can’t use it because functionality of the draftangleanalysis command changed without notification.

I hope that you can bump the developing team again. I understand that this bug is not the only problem and that (I think) i’m the only one experiencing this problem. But when a command functions in version 5, then it should be functioning in version 6.

Thank you in advance, sorry that i need to notify again.


Do you have any sight on a solution?

Thanks, Daan

Hi Daan - I gave it another bump and it looks like Wim did as well…



Some things just take higher priority than others…this (IMO) was very low on the priority list… but since it seems to be so important in this one case, I went ahead and fixed it.


I’d also like to point out something here… Just because V5 does something, doesn’t automatically mean it’s the defacto… I could argue for quite a while why analysis modes should override an object’s material completely instead of partially… There are all kinds of things that V6’s display does now that V5 doesn’t, and the parts that are different from V5 are not automatically considered “wrong”… I’m now waiting to hear how this latest fix has now broken the expectations of some other user…


Thanks Guys, now it works in the latest build available.
I’m glad that I can use Rhino 6 now.

@jeff , thanks for wending ahead the prioritylist!


@jeff In addition to the issue, the transparency on NURBS surface with analysis works fine, but with a unselected mesh with draft angle analysis, there’s again no transparency.

When the mesh is selected, then there is transparency on the mesh with analysis. Is there a possibility that this will also be fixed? Maybe the same issue? Thanks again.

@daan.eke I’m not seeing that here…the object(s) remain transparent during analysis, selected or not. What display mode are you using? Have you made any adjustments to your display mode(s)? If so, which settings?

I know it’s probably pretty simple to repeat there, but an example 3dm means we’re working with the exact same thing.


@daan.eke Never mind… I’m seeing it now… It turns out the objects are transparent…but for some reason when it’s a “mesh” object, the order they get drawn in is wrong…which means any objects behind them will be occluded…ruining the “transparency” effect.

I’ll fix it.


Allright, looking forward for the new release. Thanks!

@jeff Sorry, i hope that I’m not irritating. Can you test one more thing? (I think also a draw-order issue).
When I have a _Picture with a patch surface with analysis laying above this picture, the controlpoints that are above the picture are not visible. This is only the case with the draftangle analysis active.

In the image you can spot the problem. Left no controlpoints, right controlpoints normal visible.

I hope that you can also fix this :slight_smile: Thanks in advance.

Hey @daan.eke, no worries…it looks to me like Rhino is the irritating one :slight_smile:

I haven’t tried this yet, but my guess is that this is exactly the same problem I mentioned above…something is causing analysis mode’d objects to get drawn out of order… I just need to find where and why. I haven’t yet, but it’s on my list (with a higher priority this time :wink: )


Hi Jeff,

Is there any sight on a solution for the problem as mentioned above?

Thank you,


I do not see this here, if I understand…

Wiggly surface is above/closer to the camera than the Picture object.