Downgrade link?

Anyone have a link to a previous version of Rhino 7?
I’m getting a bug which is making it pretty much unusable right now, and I’m on a deadline.

Anything prior to:
Version 7 SR12
(7.12.21313.6341, 2021-11-09)

would be great. Thanks in advance!

Have you tried yet the Rhino 7.13 service release candidate? Bugs have been fixed… Check under Help > Check for Updates… The dialog will allow you to set the update frequence to service release candidate.

It would help to know what bug exactly you are facing.

Yes I tried that. Using it right now.
Doesn’t seem to be working.

I’ve managed to create some viewports that work ok, but then others won’t…

You mention some viewports are not working. To me that sounds like driver problems, a downgrade likely won’t help. If you have had very recently a Windows update I suggest reinstalling the latest driver for your GPU - make sure it is a clean install.

Thanks, I’ll give it a try. What’s a clean install? Do I need to uninstall the driver first?

FYI, this is the post where I list my issue:

Can you please post the entire text of the Rhino command _SystemInfo?

Just upgraded the driver, but still seeing the issue:

Rhino 7 SR13 2021-12-7 (Rhino 7, 7.13.21341.05411, Git hash:master @ 45edb3f0b4f8cd1af41e883b112aea508d01118e)
License type: Educational, build 2021-12-07
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 11-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 497.09
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-26-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 6\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino6.rhp “Karamba3DLicense”
C:\Program Files\Bongo 2.0 (64-bit)\Rhino6\Bongo.20.rhp “Bongo 2.0”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\Andrew\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\Crayon (43f0446f-00a7-4ff3-864f-0d3af5e47e2b)\1.0.7753.35014\Crayon.rhp “Crayon”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Bongo 2.0 (64-bit)\BongoUI.20.v60.rhp “BongoUI20v60”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.13.21341.5411
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.13.21341.5411
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.13.21341.5411
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.13.21341.5411
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.13.21341.5411
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\NamedPositions.rhp “Named Position”
C:\Users\Andrew\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Please try disabling all third-party plug-ins, restart Rhino and see if the problem persists.

Hi Nathan, that appears to have fixed it, thanks!
I guess I can try reloading one by one to see which one is the culprit, but to be honest I won’t be using any of those plugins for a while so I might just keep them off.

Thanks again, you’re a lifesaver!

Good to hear there is a temporary solution! For now I’d focus on your deadline first, then revisit this topic when you have the time.

Will do, thanks again!

One of the most likely candidates would be V-Ray. Lots of related crash reports being posted recently.