Dots/text get some sort of artifact


#1

Hi,

Does anyone else have this problem?

Text and dots get some sort of artifact. When I change font it works for a while, but gets back to this stage ones saved/closed/reopened.

Might also be my graphic card that’s the problem but haven’t made any changes to it since installing rhino 6 coulpe of days ago.

Is it me or is it a bug?

Best regards


(John Brock) #2

What display adapter do you have?
What display adapter does Rhino see in Options > View > OpenGL?
What is the date of your display adapter driver?


#3

What display adapter do you have?

Nvidia Quadro M1000M

What display adapter does Rhino see in Options > View > OpenGL?

Quadro M1000M/PCIe/SSE2

What is the date of your display adapter driver?

23.21.13.9077, (updated yesterday without any success)

Best regards


(David Eränen) #4

Hi @socken,

Could you paste the whole text from Help -> System Information... ?


#5

Rhino 6 SR1 2018-2-6 (Rhino 6, 6.1.18037.13441, Git hash:master @ 5a33e6871b94d32ba552468218cef0ad8d3d1263)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Quadro M1000M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.77)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-23-2018
Driver Version: 23.21.13.9077
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\LayoutManager (23664189-f095-4e9c-8f6d-1073c2c60efc)\0.2.6.0\LayoutManager.rhp “LayoutManager”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”


(David Eränen) #6

@socken I can’t repeat it. Does this also happen for you if the text style is set to Default and Height to 1.0? Did you have this problem in Rhino 6.0 or did it appear after Service Release 1?

@stevebaer Is this the text drawing shader that is acting up or could it be core text code?


#7

Yes it does.


#8

I’m allmost certain that it was in the first release as well.

I also have the problem with “hideindetail” where lines/artifacts appear that’s not selectable.
Don’t know if this is the same issue though.

best regards


(John Brock) #9

Interesting.
I am running a Quadro P2000 and the same driver.
I’m not seeing this issue at all.


(Steve Baer) #10

I’m pretty sure this is a display driver bug. Some drivers seem to have problems with the way we draw text in Rhino 6.

There is a test command in Rhino called “TestGlyphy” which changes how text is drawn. Running this command to disable glyphy may fix the text display for your Rhino. The quality is not quite as good as when glyphy is enabled, but it may get you back in a state where the text displays correctly again.


#11

I’ll try it next time the problem shows up. (It didn’t show up when i tried it out this time)

The artifacts from “hideindetail” still was there though. But I don’t know if you want me to post this as a sepparate issue.


#12

Hi,
I tried “TestGlyphy” and that changed the text back to readable state again.
Best regards


#13

Hi all,

I have installed SR4 and find more on this.issue.
the language is Swedish, and the picture sould have the letters: “ABCÅÄÖ”. As you can see the Å isn’t displayed correct.
Even if I use default style the problem occurs.

When using TestGlyphy it’s fixed.

Dont know if this helps anyone, but at least now you know.
Cheers


image


(John Brock) #15

Thanks.
I’ll let the developer know about this new detail.