Dots pattern in material, how do I make it look good big?

Looks perfect on a small surface but gets real weird on the big one.

Hi ATH, please could you upload the model so that I can take a look what is causing the problem?

You can upload from this page: http://www.rhino3d.com/upload
Set recipient to jussi@mcneel.com.

  • Jussi -

screen problems.3dm (1006.1 KB)
no need to go there, it’s a small file. thanks for taking a look.

Thanks @ATH
That wall has procedural texture on the material (Dots texture on transparency channel). Therefore it requires advanced texture preview (ATP) to show the material in viewport. ATP works better on small objects like that surface in your model. One way to make your wall preview with more detail is to split it into smaller pieces. I used BooleanSplit to test, and here’s the result:
screen problems split objects.3dm (988.3 KB)

@ATH, another option is to use bitmap instead of procedural Dots texture. Like here:
screen problems bitmap.3dm (708.7 KB)

that is what I ended up doing.