Does rendering in WIP have a memory leak?


#1

I’m running some moderate architectural renders, and a number of the recent renders will get to around 96-99% completion before I get a notification (pictured) that my system has run out of memory. In particular, it shows that RhinoWIP is using over 130 GB of memory. Is this a bug? Is it my computer? Are there settings that I can optimize?

I appreciate any insights!

Rhino 6 SR14 2019-2-12 (Public Build, 6.14.19043.12076, Git hash:master @ 7149c231e179e11960d27ac5c99c5713fe410254)
License type: Beta, build 2019-02-12
License details: Cloud Zoo. In use by: Isaac Fresia ()
Expires on: 2019-03-29

Apple Intel 64-bit macOS Version 10.14.3 (Build 18D109) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro11,4
Machine name: owner’s MacBook Pro
Language: en-CA (MacOS default)

Intel Iris Pro OpenGL Engine (OpenGL ver:4.1 INTEL-12.4.7)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel Iris Pro
Displays: Color LCD (221dpi 2x)
Screen size : 1440 x 900

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Broadcom Corp.: Bluetooth USB Host Controller

Bluetooth devices
None

Third party kernel extensions
com.intel.kext.intelhaxm (7.3.2) 58DFBE80-E54A-3EFE-B38A-215C5ED8E828

Third party plugins
/usr/lib/log/liblog_network.dylib

Rhino plugins
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.14.19043.12076
/Applications/RhinoWIP.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.14.19043.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.14.19043.12076
/Applications/RhinoWIP.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.14.19043.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.14.19043.12076
/Applications/RhinoWIP.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.14.19043.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.14.19043.12076
/Applications/RhinoWIP.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.14.19043.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.14.19043.12076
/Applications/RhinoWIP.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.14.19043.1002


(David Eränen) #2

Hi, thanks for reporting!

We created this: https://mcneel.myjetbrains.com/youtrack/issue/RH-51200. I will try to reproduce the issue today.

-David


#3

Thanks for following up! Interested to see what you find.