Doc.NewSolution crashing Rhino


I have ported code for my optimization plug-in from a C# component “prototype” into a “proper” component.
However, I’m now experiencing crashes when resetting the values and recomputing. The code I’m using looks like this:

doc.NewSolution(false, GH_SolutionMode.CommandLine);

Rhino crashes when I start the NewSolution, and I also don’t see the slider changing.
Any idea why that might be/possible solutions? I didn’t have this problem when running the code inside a C# component.

Thank you!



I don’t know what could be going wrong, any hope of seeing a call-stack for the crash, or an error message?

Thanks David, I tried what you suggested (and a couple of other versions), with the same result.

Here’s a stack trace I managed to get out, not sure if it’s very helpful.


Do you get a Rhino crash window? If yes, did you submit the crash report? While the window is open there’s probably going to be a RhinoDotNetCrash.txt file on your desktop. This file will contain the most useful information for me.

Thanks David, I managed to solve the problem using the RhinoDotNetCrash.txt file.
For some reason, the WaitHandle I used to check if the document was solved was not referencing the Grasshopper document correctly.