Dissapearing Z Axis


#1

Z axis tends to vanish in Shaded view. It’s been doing this for at least the last 3 builds.

This usually occurs when zoomed in very tight (like when chamfering solid edges) and when you zoom back out the Z axis vanishes.

Going back to Wireframe it will show up, as below:

Going back to Solid it vanishes again.

Once it does it’s gone for good until you save and reopen the file.

Software information

Software versions
Rhinoceros version: 5.0 WIP (5A805w)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.2 (Build 14C1514)

Plug-ins
None

Third party kernel extensions
com.rim.driver.BlackBerryUSBDriverInt (0.0.68)
com.BT.kext.bpkkext2 (1.0.0)
com.nvidia.web.NVDAResmanWeb (10.0.3)
com.nvidia.web.NVDAGM100HalWeb (10.0.3)
com.nvidia.web.NVDAResmanTeslaWeb (10.0.3)
com.nvidia.web.NVDANV50HalTeslaWeb (10.0.3)
com.nvidia.web.GeForceWeb (10.0.3)
com.nvidia.web.GeForceTeslaWeb (10.0.3)
tc.tctechnologies.driver.PaeFireStudio (4.0.0 14255)
com.kensington.trackballworks.driver (1.2.0)
com.Cycling74.driver.Soundflower (1.6.5)
com.nvidia.CUDA (1.1.0)

Hardware information

Computer hardware
Hardware model: MacPro5,1
Processor: Intel Xeon CPU X5690 @ 3.47GHz
Memory: 24 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 120 512 MB
Memory: 512 MB
Screen size: 1920 x 1200, 1920 x 1200
Displays: DELL 2405FPW (94dpi 1x), DELL 2405FPW (94dpi 1x)

USB devices
Kensington: Kensington Slimblade Trackball
SanDisk: Cruzer Glide
Apple, Inc: Apple Keyboard
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.3.1 343.02.02f04
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


(Dan Belcher) #2

Sorry for the slow uptake. I’m unable to repeat this on my machine…maybe my test model isn’t large enough? @pascal are you able to replicate this on your machine?

(I’m creating a large ring-like shape and then zooming into the center of it - all in Shaded mode with the z-axis visibility turned on).


(Pascal Golay) #3

If Show Z axis is on in the display modes (Rhinoceros menu > Preferences > Display modes) then it works, so far, as expected.

-Pascal