Display white as white in shaded mode

rhino5
unhandled

(Liis) #1

Hi everybody,

I am new to this forum, so I am trying my best to be as precise as possible while explaining the problem I stumbled upon. At the office we switched from another CAD Programm to Rhino recently and we are very satisfied - 3D modelling is great!
So now to the problem:
The idea is to use the 3D Model on the layout in top, side and front view. Since the model is a work in progress through the whole project, we have to adjust its shape all the time. It would save us time, if we could skip the “Make2D” command. Our prefered display mode is Shaded. The thing is that the shaded mode displays white as grey, but we want white to be displayed as white in the pdf. For further explanation I attached to shematic sketches. How can I achieve this?

Thanks a lot.
Regards,
Liis



(Nathan 'jesterKing' Letwory) #2

I’d make a copy of the Shaded mode, then disable the lighting and set shading to object color.

Also probably a good idea to set gloss to 0.


(Liis) #3

Thanks Nathan for your response.
I had already disabled the lighting and set the shading to color object. What I had missed was the Gloss option. When Gloss is set to 0, white is still displayed as grey. When it is set to 1, it is light grey. The thing is, that now black is not black anymore, but dark grey.


(Jakob Normand) #4

Hi @Liis

Could Technical be used? Enable shading the faces and remove gloss, as previously mentioned. Note that black can’t be RGB 0,0,0, as it’ll display as white. Nudge it to RGB 1,0,0, and it’l come out black (or rather, really, really close to black).

HTH, Jakob


(Nathan 'jesterKing' Letwory) #5

Attached a display mode modified from Shaded to do what you want.

I found a bug through this btw, so for black you should use “almost” black, i.e. at least one of R, G or B needs to be 1.

See the attached 3dm and ini files:

Flat Shaded Object Color NoLighting.ini (12.5 KB)
Flat Shaded Object Color NoLighting.3dm (40.1 KB)

The mode gives me


(Nathan 'jesterKing' Letwory) #6

Hadn’t noticed your message, kinda found the same issue.

I have reported the black-draws-white as RH-45474


#7

Has been this way since Rhino 1.0… or before. --Mitch


(Liis) #8

Unfortunately I can’t open your file, since it seems to be from Rhino6 and I am still using Rhino5. Could you please save the file under an older Rhino Version? Thank you!


(Nathan 'jesterKing' Letwory) #9

time it got fixed then ^.^


(Nathan 'jesterKing' Letwory) #10

These files work in v5

Flat Shaded Object Color NoLightingv5.ini (11.6 KB)
Flat Shaded Object Color NoLightingv5.3dm (44.4 KB)

image


(Liis) #11

Thank you guys! It worked and now looks exactly as I have wished for!