Display Render Mode Black

To all users

Just recently if I change a material property in brazil then use either Render display mode or Neon display mode all I get is a black screen. Once the screen has done this once in any file it then seems to be stuck in this file. When I do a brazil full render it all works fine.

Any idea cause we have none here

regards Jahn

Furthermore to this I have found it is connected to the brazil environment setup.
when I use a hdri in equirectancular texture the screen goes black when in rendered or neon mode dispaly

Narrowed it down. If I create an environment in brazil the screen goes black if I do the same with rhino render it works then I change the current renderer to brazil then the enviromnet work!! Think this is a bug.

Cheers jahn

What environment type are you using and can you provide the HDRI used?

Brian thanks for the reply

Doesn’t seem to matter what hdri image or bmap I use in GI environment.


I saw something like this earlier today on a computer with no Brazil and no Neon.
In Rendered display mode,the screen is black.
If you turn off Use accelerated hardware does it display right? (Mine does.)
What kind of video card do you have? NVidia?


Thanks for your reply. If I turn the accelerated hardware off it fixes it for the neon but strangely not for the rendered mode.I have a Radeon HD7700 graphics card- not the best but pretty good so far. This problem has only started in the last couple of weeks and once it happens in a file once ( regardless of file size) it seems to be stuck.

Regards jahn

This sounds like a GPU driver issue now. Can you post a screenshot of your Options>View>OpenGL page please when accelerated hardware is on? I would also try disabling anti-aliasing to see if that fixes the issue.

OK, Thanks for the info.
It sounds like not quite the same thing I saw, but maybe related somehow.


Screen shot as requested
Regards jahn

O.k so when I turn the accelerated hardware mode off and set the antialiasing to none the render and neon mode work again but with a pretty poor image. No shadows etc.
This is not really a workable solution but I guess it narrows things down.

The funny thing is it all works fine until I change a material or a property in the render mode then the glitch is perminately in the drawing- we have tried these drawing then on a different machine with the same specs and got the same result!

Could it be the last update?

Dazed and confused and wasting client time!

I would update the driver for the GPU next. The one installed is from 2012 and I bet that’s the problem. Here’s a link to help you locate drivers http://wiki.mcneel.com/rhino/5/video/troubleshooting/failure

For Radeon cards look for drivers from December 2013 or January 2014. The latest AMD drivers have been known to have other OpenGL issues.


Unfortunately this made no difference. The glitch happens only when in rendered or neon display mode I select an object- Properties- Material (object) and change the material type.

Attached is a sample model see what you get-render test 2.3dm (1.5 MB)

Hey Brian

did you get time to look at that file.?

Updated latest driver etc and tried in on other machines got the same thing- Should I install an older version of rhino.

regards jahn

The link for the 3dm isn’t working… it may be a problem with the forum. @steve do you see this too?

Can you upload it to www.rhino3d.com/upload to my attention in the meantime? I’ll see if I can reproduce it here but I don’t have a Radeon card if that’s indeed the cause. I don’t think you mentioned your software versions… or did I miss it? Is this Rhino v5 SR11?