Display panel locked on wireframe and problem display artic (update, resolved by canceling the Artic mode from the Rhino 5 settings)

unhandled
artic

#1

Rhino 6 Mac WIP build 6.12.18310.10526 Os 10.13.6 iMac Late 2012
The display panel is set to wireframe by default and even if you change other display modes from the panel, nothing happens (and sometimes trying Rhino closes). Also the artic visualization no longer works (see photo).
Rhino 6 SR12 2018-11-6 (Public Build, 6.12.18310.10526, Git hash:master @ 796297cb9cb110b9a02b7734498c64c8583a4eb8)
Licence type: Beta, build 2018-11-06
License details: Cloud Zoo. In use by: Simon ()
Expires on: 2018-12-21

Apple Intel 64-bit macOS Versione 10.13.6 (Build 17G3025) (Physical RAM: 32Gb)
Machine name: iMac di Simone
Language: it

NVIDIA GeForce GTX 680MX OpenGL Engine (OpenGL ver:4.1 NVIDIA-10.32.0 355.11.10.10.40.102)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.1
Shading Language: 4.10
Driver Date: (null)
Driver Version: (null)
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB
Displays: iMac (109dpi 1x)
Screen size: 2560 x 1440

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Bluetooth USB Host Controller
Samsung: Portable SSD T5
TOSHIBA: External USB 3.0
GenesysLogic: USB3.0 Hub
3Dconnexion: SpaceMouse Pro

Bluetooth devices
Unknown:
Apple: Apple Wireless Keyboard
Apple: Apple Wireless Trackpad

Third party kernel extensions
com.3dconnexion.driver (10.5.3) 10F49F3A-732E-3034-BB45-320FC96950DC

Third party plugins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Rhino plugins
/Applications/RhinoWIP.app/Contents/PlugIns/RhinoBonusTools.rhp “Rhino Bonus Tools” 6.12.18310.1002
/Applications/RhinoWIP.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.12.18310.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 5.1.2015.132
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.12.18310.10526
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.12.18310.10526
/Applications/RhinoWIP.app/Contents/PlugIns/Alerter.rhp “Alerter” 6.12.18310.1002
/Applications/RhinoWIP.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.12.18310.1002
/Applications/RhinoWIP.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.12.18310.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.12.18310.10526
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.12.18310.10526
/Applications/RhinoWIP.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.12.18310.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.12.18310.1002

-Simon


Arctic Display Mode
Rhino 6 for Mac WIP build 6.12.18345.12306
#2

Any news on this? Thank’s
@dan @pascal @

-Simon


(Pascal Golay) #3

Hello - I’m loading up the latest build here to test…

@Zsimon - I can confirm that the panel is disconnected… but Arctic does seem to work here if set from the viewport menu.

https://mcneel.myjetbrains.com/youtrack/issue/RH-49426

Thanks for the report.

-Pascal


#4

Hello
The artic mode worked for me until the previous wip. Any idea why it does not work now?

Thank you

-Simon


#5

Arctic mode just shows a wireframe model to me, it does change the gridlines to white though. Also when changing display modes the r/h side panel does not match up with the display mode selected from the view dropdown menu.


#6

Same thing here with the latest version WIP (6.12.18317.12076, 2018-11-13)

-Simon


(Pascal Golay) #7

Hello - so far I am not able to repeat this here- it may just be fixed. Can you try the next WIP and let us know?

thanks,

-Pascal


#8

Of course

-Simon


#9

Updated to the latest WIP. The problem of visualization of Artic and display models remain.

-Simon


(Dan Belcher) #10

Is this the same problem as reported here?


#11

Hi Dan.
I would say yes. However, it is important to note that until the third-last WIP, Artic worked perfectly.

-Simon


(Pascal Golay) #12

Hi Simon - does the problem go away, even temporarily, if you do as John said in that thread and reset preferences: https://wiki.mcneel.com/rhino/mac/resetprefs
?

-Pascal


#13

I see. But I have very personalized preferences and I do not want to risk losing them or having to redo from scratch. I will wait for a definitive fix.
thank you @pascal @dan

-Simon


(Dan Belcher) #14

Changing the display mode in the right-hand sidebar should be fixed in the latest RhinoWIP. Please give it a try.


#15

Good news. The display mode changes to the right-hand sidebar. Now the “artic” visualization mode also works.

-Simon


#16

Hi Dan.
With the latest WIP version, the Artic visualization has stopped working for me.

-Simon


(Dan Belcher) #18

Hey @Zsimon-

It’s working fine over here. Has your SystemInfo changed since that posted above?


#19

Hello Dan. Everything has remained as before, no change.
WIP build 6.13.19002.12026 the problem persists.
-Simon


#20

Arctic display mode not working in latest WIP (was working for me in previous)


(Wim Dekeyser) #21

Artic works on my system running 6.13.19002.12026.Which version are you running?
Also, please post your SystemInfo here.