Display mode capable of hiding mesh triangles?

Is there a display mode capable of hiding the internal edges of polygon meshes? The silhouette should remain. Like so:

I’d like to achieve this flat/abstract style for architectural axonometry, and there’s a lot of imported mesh furniture with nasty mesh triangles (which wasn’t the best idea to use). VisualArq ‘Hidden’ and ‘Conceptual’ modes can do this, but they unfortunately have bugs (objects go missing, black artifacts…), so I’m looking for an alternative - which I can’t seem to find in the o.o.t.b. display modes.
Thanks a lot!

You could try the ngonulate command to convert coplanar sets of triangles in a mesh to ngons.

Hi Eugen,
Maybe you mean this setting. Turn it down to 0 to show just unwelded edges.

Thanks! Ngonulate is a R7 feature. Got to stick with R6 a little longer, since VisualArq (which I need) for R7 is not out yet.

Thanks, that could work. Would mean I’d have to clean up the furniture meshesm, though. Since there are plenty, and time’s up soon, I got to consider carefully.
Edit: … and it would not render the silhouette from free angles, which I need.

It’s in V6

Hm, no. I type ‘ngonulate’, and nothing is listed.

I think the command is “AddNgonsToMesh”



Sorry, early morning. I could have sworn it was in V6, but I see you are right. AddNgonsToMesh is not what I was referring to

QuadrangulateMesh is another good one to try (and I just checked to make sure it is in 6.31 :slight_smile: )

Ok, quadrangulate is surely there.
However, to get finished, I went down the dark alley and printed one version of the axo in ‘hidden’ (where for obscure reasons some facade parts are not displayed), and ‘shaded’ (with the same look except the mesh) and blended them together in Photoshop. Brrr!
But it worked…
Will report that bug to the VisualArq people after the competition.
Thank you, guys!

Did you try Jess’s suggestion? It hides welded edges, but won’t give you an silhouette though.

I don’t know which timezone Steve actually is, but I guess it is QuadRemesh which is in V7 only :wink:

If you are interested in high res vector graphics then you might have a look at _Make2D especially if you have the NURBS Geometry.

Alternatively you may also try Steve’s Technical display mode especially with meshes. The lines at the smooth surface transmission can easily be eliminated with the _Weld commant and the proper angle.
This is an interactive view. no need to render, just capture in realtime.You can edit that mode and disable hidden lines (make a copy of Technical)

Thanks, guys! Job’s done, there’s time to chat now.
My basic problem here was that I used high-poly furniture (Easy to download and good-looking). If there were med-res versions of it, it would have been better. Optimal would have been low-res NURBS-versions of it, but I had no time to start modelling a little library of these.

  • Make2D I tried, took forever because of the high polycount, had to cancel.

  • Tried Ngonulate, does not work too well in this case:

  • Quadrangulate does not help much, because even if the mesh diagonal edges are gone, there still would be way too many edges. If you zoom out, such a chair would look just black in shaded mode.

That’s why a mode supporting outlines is the way to go. I found (too late) the ‘Technical’ mode to do just that:

Altough the smaller artifacts are not so nice, it would be usable for the look I was after. Problem with it (besides that I discovered it too late) is that it is unusably slow! Much slower than the VisualArq ‘Hidden’ mode I used in the end (with retouching, unfortunately).

Edit: letting the ‘technical’ mode run on the scene (a 50 x 15m building floor fully furnitured) - still working, after minutes. No go.

So, it wasn’t as easy as I hoped.