Display issues updated


#1

V6 update: (6.0.17241.13071, 29/08/2017)

So on my ancient laptop the current state of play is as follows: (All view settings are default.)

Ø the picture command simply shows a white rectangle in any display mode ie no picture!
Ø The wireframe, shaded, ghosted, x-ray, technical, artistic, pen & raytraced displays all work as expected.
Ø The artic display shows shaded grey (default) objects on a white background
Ø The render view shows shaded grey (default) objects on a black background
Ø If I select an object that has an environment assigned to it, while in the rendered display, the material panel correctly renders the icon at the top. Since this is the case, and the raytraced display works correctly, I assume this computer is capable of showing both the render and artic views as they should be…?

How can I help this to happen? Does someone (from McNeel !) want to take the computer over and have a look…

cheers
rabbit

Rhino 6 SR0 2017-8-29 (Rhino WIP, 6.0.17241.13071, Git hash:master @ 4ba507bbd3a2d10cc10aa64a48c6283abe2fd544)

Windows 7 SP1 (Physical RAM: 7.9Gb)

ATI Mobility Radeon HD 4650 (OpenGL ver:3.3.11672 Compatibility Profile Context)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: ATI Technologies Inc.
Render version: 3.3
Shading Language: 3.30
Driver Date: 11-16-2012
Driver Version: 8.970.100.7000
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 1 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”


(David Eränen) #2

Hi @rabbit,

The first thing I would ask you to do is to update your graphics driver to the latest version. http://support.amd.com/en-us/download

Do things work after driver install and computer reboot?

-David


#3

Hello David
It’s a old Toshiba laptop - there is no way to update the drivers…
Thanks
rabbit

—Sent from mobile device & email—


(David Eränen) #4

That’s very unfortunate!

It sounds like Arctic is working as it should, according to your description. It’s supposed to ignore all materials and only render objects in grey:ish white with skylight shadows. Could you show me a screenshot?

Regarding the object that has an environment assigned (using the environment slot I presume?) - could you try to set reflection to 100% and in the advanced material settings set Reflection polish to somewhere around 50%. Does the material turn black?


#5

Ok David:

1] Arctic screen shot.
2] Screen shot of the render view port, which from starting out as described earlier, just went to this black silhouette; restarting doesn’t change it…???
3] And, using the same black render view as above, making the changes you asked for, turns the material white…but note the render view has returned to a shaded sort of view with no color display! Changing the. two sliders back to the default do not make the view go to black again…???

Thanks
rabbit


(David Eränen) #6

@rabbit,

Please try this for me: Remove all materials from the objects. Go into the Rendering properties panel click the Reset to Defaults button at the bottom. Go to Rendered mode. How do things look now?

Also, would it be possible for you to attach the file so that I can take a look how it works on my computer?

Thanks,
-David


#7

Ok - this with (6.0.17248.9001, 5/09/2017) which i just downloaded…
model attached.

cheers
rabbit

v6wip_test_rabbit.3dm (1.2 MB)


(David Eränen) #8

@rabbit,

I can’t see anything odd about the model. It works OK for me. I’m afraid that it might be the old drivers which are not working correctly, but I can’t say for sure.

Having said that, I would like you to test again after downloading next week’s WIP (usually released on Tuesday US time). I have made some changes that could make things work better (but please don’t get your hopes up!).

Is there no way you can get new drivers installed? What about installing a fresh Windows 10?

-David


#9

Ok David - thanks.
Once v6 ships I’ll probably retire this computer and buy a new one; its fine for V5 and everything pretty much works in the wip except for rendering, so for now I’ll just model in v6 and render in v5…

Cheers
rabbit

—Sent from mobile device & email—