Display issue after Rhino reinstall - extremely slow mesh wires (SOLVED)

Hi,

I have recently reverted back from SR13 to SR12 and the display got very very slow. I investigated for a while and found that it is mesh wires on a slightly denser meshes that cause the slowdown. Surfaces/polysurfaces with tons of edges are fine, dense meshes with no edges visible are fine, but meshes with edges slow down to a crawl/unusability. I wend back to SR13 and it is the same - something must have gone wrong during the reinstall, even though all options, settings and customizations were preserved. OpenGL tessellation is ON, Running is Safe Mode doesn’t solve anything.
@stevebaer - would you have any ideas/suggestions how to fix it? I was trying to avoid minor problem with SR13 (materials bug) by reverting back and now I made the whole Rhino unusable, no matter what SR I use.
Need to work in V5 for now that works just fine, but can’t in a long run. Hope for some ideas how to fix this!

thanks,

–jarek

Tried Install Repair - no luck. Also, it happens in all display modes… Safe mode does not help either.
.SysInfo.txt (2.6 KB)

TestMaxSpeed on the same file in V5 and V6 is <1s. vs 35s.,that’s how sluggish V6 became now here. Again, only mesh wires are slowing down the display; with them off, all is very fast again.

EDIT: Deleting user profile did not help; also importing slightly older Options.ini file did nothing to fix it.
Even went to Advanced Options and checked each that had OpenGL in name ON/OFF, no change… : (
Seems like something deeper got messed up.

I also tried and deleted all Rhino 6 Registry keys, both LocalUser and LocalMachine, then clean reintstall. The problem persists.
One weird thing I noticed is in V5, which works fast as it used to, when I turn on BBox Display, the whole heavy mesh becomes box, in V6, the mesh shill shows in BBox Mode, but the wires disappear and bbox edges are shown, which results in fast display. Never before I had to try bbox display so not sure if this difference is something default/expected, but I thought I would mention it since I am a bit desperate for a solution and hope any hint may help to get it back to normal.

@Jarek What happens if you type TestToggleVboUsageHeuristic?

Hi @DavidEranen, tried that but toggling that makes no difference in display speed. Any other ideas?
I remember when developing the new display engine in V6 @stevebaer mentioned that mesh edges are drawn using different algorithm than curves and brep edges and over here it seems like it is only mesh wires speed problem, everything else works very fast. I tried everything I can think of but still have Rhino 6 unusable due to that issue.

thanks again, hope there is something else I can try!

–jarek

Your display driver looks brand new. Did the problems start right after you updated your driver?

No, everything worked fine with the new driver. The problem started when I reverted back from SR13 daily build (which worked fine) to the SR12: http://files.mcneel.com/dujour/exe/20190122/rhino_en-us_6.12.19022.16441.exe That’s the first time I experienced the extreme mesh wires lag.
Since then, It stopped working normal no matter what I tried, updated to latest daily Rhino build, reinstalled few versions or the video drivers, and all I mentioned above (deleted user profiles, Rhino 6 registry enries, tried safe mode…)

I remember when installing older SR while having the SR13 installed, it went through but the version was still new SR so I did not test then. Then I went to modify the SR13 installation and before uninstalling it completely I went through and tried repair, and then “modify” install. One non-standard thing I did was the uninstaller started downloading files for offline deployments (some C++ redistributables) which I canceled half-way since it was taking forever. I wonder if that messed something up. But after that removed and installed SR12 and SR13 many times, and all works fine except for the mesh wire slowness… Unfortunately this makes Rhino 6 unusable on my end now : /

Anything else to try or the above give you any ideas to get it back to normal ?

Make sure Rhino is not running. Try going to %appdata%\McNeel\Rhinoceros\6.0 and rename the settings and shader_cache directories to something else. That may help.

Thanks Steve - just tried it, but still no luck :frowning: (I tried before wiping these folders clean before reinstall anyway).

I tried looking and changing the OpenGL settings one-by-one, but I did not see any change either…
openGL_Advanced

You’ve probably already tried, but just in case… make sure to disable all of those 3rd party plug-ins and then restart. Always good to eliminate any possibility those guys are getting involved.

Tried it again now as well, still nothing. Is there anything else on System level, other than video driver, that could affect this? Any OpenGL or system libraries or frameworks that could be reinstalled? I will try anything at this point…

I can’t think of anything. If you can get a hold of the previous driver, that would be what I would try next. Sorry this is happening to you.

Oh nooo… I was hoping the mesh-wires-only issue can give you some clues. I tried installing older drivers as well last night. Rhino 5 works just fine with the mesh I am testing ( ~100K polygons, relatively dense wireframe) - it is blazing fast as V6 used to be. It’s something specific that happened to V6, but considering that I wiped clean the registry and user settings, got rid of the plugins etc. I suspect this is on deeper level…

@jeff - as another Rhino display guru - would you have any suggestions what to try to get the V6 mesh wires display speed back to normal? Seems like so far we have exhausted obvious things to try…:frowning:

Ugh…given your timeframes, this might be something I broke while fixing another problem for Grasshopper…it’s never easy is it…

Can you please provide me with a mesh that I can test with here… It’ll be easy for me to try your mesh, comment out my change, and the try your mesh again to see if indeed my change is the cause.

If it is, obviously I’ll fix it and go back to the drawing board for the other problem.

However, since changes we make in SR12 automatically roll into SR13, I would expect SR13 to have the same problem… Can you please try the latest SR13 and confirm that it too is slower than you remember?

I’ll await for that mesh…

Thanks,
-Jeff

Hi Jeff, thanks for looking into it. I just uploaded a sample file I test with, but it happens with any mesh with decent amount of wires. Any display mode; typically I use: Wires=0, All edges types=1.
If you had a chance to read above attempts, you will see it happens both in SR12 over here and latest daily SR13, but I would think it is something that broke on my end and not yours - it all worked fine until I reverted back from SR13 to SR12 due to some other minor issue, since then, all we have tried failed to fix it, both on Rhino and drivers level… Also, V5 works fine and very fast with the same file.

Thanks!

–jarek

I realize that…but I really don’t like guessing at using what users are using…and hope I get things exactly right so that I’m working/using exactly what you are. Also, it might sound simple to “just create a mesh”…but having to create something for every issue reported takes up a lot of time…so it’s just easier, faster, and 100% more accurate if you just supply a file that you’re using.

Yes, I did read everything you wrote, but I still could not determine which SR13 you were using originally…it changes daily remember. My guess is that if it’s something I broke, then this is what happened:

  1. You had a version of SR13 that didn’t have my change
  2. You rolled back to the latest SR12 that just so happen to have my change
  3. You then went “oh crap!” and went back to SR13… but at that point, the SR13 version you went back to had my change in it.

What I suppose I could do is provide you with a link to the SR13 installer that doesn’t have my change, and see if it works.

Hmmmm…that might be better. Do you happen to remember the exact version of SR13 you were using when it was working?

-J

Did you address the mesh file to me or someone else? I’m still not seeing any uploaded file email.

hi Jeff,

The whole thing started when I was on Version 6 SR13 (6.13.19021.12581, 1/21/2019), which was working just fine. Because of other issue, I rolled back to this one: http://files.mcneel.com/dujour/exe/20190122/rhino_en-us_6.12.19022.16441.exe

And that’s when things started to go super slow with mesh wires. Since then I went to latest daily build: 6.13.19023.9201, 1/23/2019 which is still very slow…

so - does it give you any clue?

PS. I addressed the file to jeff@mcneel.com