Display Banding Anomalies in mac WIP

I am getting some display anomalies from lofted surfaces in Mac WIP V5.4 (5e33w)

It appears as though bands of the geometry on the flat surfaces are not orientated the same way and therefore appear shiny. See image…

Steps to Reproduce:

  • Create 2 planar closed crvs (i have not test with curvy crvs)
  • Move 1 crv up into parallel plane
  • Offset both crs
  • Loft the offset crvs
  • Loft the original crvs
  • PlanarSrf the 2 sets of crs (Original1 with offset1 and Original2 with offset2)
  • Join all

Should get a closed polysrf “tube” with banding error, see example attached below! Banding only occurs after the join?!

DisplayError.3dm (2.5 MB)

Even without opening your file, I’m going to hazard a guess that you have crease splitting turned off…

(opens file…)

Yes, exactly. Type CreaseSplitting and set it to “Yes” - looks like it’s set to “No”. That will fix it for future modeling.

To fix the existing model: select the object and run DivideAlongCreases > SplitAtKinks=Yes

How did crease splitting get turned off? That’s the sixty-four thousand dollar question. Sometimes it just “happens”, nobody knows why. I see this more frequently now on Mac Rhino.



Thanks Mitch, that did the trick!

Yeah, me too. A fix would be really welcomed.


Well, this bug has been around a long time, simply because nobody knows what causes it and thus how to fix it. As this setting is “exposed to the public”, it could be that:

  1. somehow people are accidentally setting it without realizing it
  2. some plug-in or script somewhere is doing it
  3. some obscure, very-infrequently used core code in Rhino is setting it (bug)
  4. none of the above…
  5. all of the above…

I guess we’ll just have to wait and see if V6 inherits this tendency from V5…


I know… Interesting times (waiting for V6) :sunglasses: