Displacement: Reduce Mesh


Can somebody tell me how the Reduce Mesh option in displacement works please? Does it, for want of a better explanation, only let the mesh density count go upwards to the ‘ceiling’ value set in the reduce mesh parameter in the panel?

Or, in the generation of the displacement, does it shoot past the ‘ceiling’ value, to then come back to the ceiling value you’ve set?

Example: I extracted render mesh of something at the ‘Very High’ setting which produced 5mil polygons, capturing the necessary detail for rapid prototyping. I then reduced this by 75%. This reduction obviously takes a while. Would I have been better off, and Rhino quicker, if instead having the Very High setting combined with the polygon count I’m aiming for? Or would this actually just be like running the two commands in tandem, and take forever as well?

@BrianJ , maybe you know who to ask?

Hi @Jonathan_Hutchinson1 ,

The Displacement property doesn’t have a Reduce Mesh setting but I think you might be talking about the max faces setting and how that correlates to the quality setting such as Medium or High. Essentially it overrides it if that helps. I never ever use Very High or Extremely High myself, if I need that level of displacement I’ll use a mesh modeler like Z Brush and then jump back into Rhino. When using Rhino’s Displacement property, I always use a resample texture to blur the source image a bit too, that way you can control the detail in the resample pixel count and keep the displacement quality on High. The commands ShowRenderMesh, HideRenderMesh, ExtractRenderMesh and PolygonCount after extracting can all help gauge what you’ll get too.

Yeah that’s right. Max faces I mean. It was for a very specific sort of ‘brushed’ texture, and a very small height, ~.2mm (for high res rapid proto).

So if I have Disp set very high, Rhino should in theory just do the best it can with the max faces I set, rather than making a super dense mesh? (I know in this case I probably could’ve done with upping the render mesh a fair bit first too, as per).

In my tests here, the max face setting drove the result despite the quality setting. The extracted render mesh showed a difference of 1 polygon only so it has some impact I guess but to me it looks like max faces just overrides the quality setting if that number is not as high as what the setting produces which is a factor of the image used the objects existing render mesh. Again, I use a resampled texture to blur the source image and don’t go above the High setting. For a texture this fine I guess I might try it on Very High if other variables didn’t allow for the detail on High. If you post a file I can take a look but I’m guessing otherwise.