Displacement not working on imported modes

Hi - thanks in advance for any help. I at
Using rhino for windows and am trying to apply a displacement texture to a (somewhat complicated but not dreadful) shape. However no matter how long I wait for it to long, even after an hour it still won’t work, and I have a fairly decent PC I use for gaming as well. When I try the same thing on any model that I make in rhino it works fine, and loads the displacement in seconds, even on very high. I have tried with a much simpler imported model and the displacement still won’t work. Please help!

The image is my model

May be utterly unhelpful here. Have you tried 'RequadMesh` on this object? It is very dense.

1 Like

Hi - thanks for the reply - no I havnt! I’ve very new so all suggestions are very helpful. I will try thag

Ok - so I reduce the mesh a lot and it looks a lot better now, but still won’t seem to show the displacement.

If you can share the original object, or some other example you cannot displace, then someone can have a look.