Displacement mapping wishes

Mapping wishes:

If I don’t choose a mapping style, then go to the texture mapping button and click on Show Mapping, nothing shows up. I guess that’s true of all applied textures, but why? I guess it is UV by default, but how can the user tell? Maybe when the user clicks on ‘Show Mapping’, the command line could say, “can’t show widget for UV mapping” or something more useful? Right now the command line says “None of the selected objects has a mapping on the specified channel” but is that true or useful in this case? Basically, as seen through the eyes of a new user, I’d think the user would click on that button and have no idea how to modify the mapping.

Another problem: the mesh created by displacement always seems weird (often jagged.) I guess I wish there were a smoothing option in the displacement dialog or something like that.

Once I apply some non-uv mapping, the widget works well but it would be really useful to be able to see the image that I’m applying as a displacement map in context (basically, be able to see the texture previewed as if it were a color map.) I mean, if I’m applying a bitmap, could I toggle to see that bitmap instead of a displacement preview somehow, just to help me align the texture, then I’d want to switch back to displacement live view to define the height and other attributes. This might make it easier to place my bitmap where I want it without waiting for the displacement to refresh constantly.

One more texture mapping general observation: Whenever I haven’t rendered for a few months and I want to apply a texture to an object, I first click on the Texture Mapping button, and then I try to figure out where I select my image to apply as a texture map. And of course it doesn’t exist in that dialog box, but I find that really confusing. I’m guessing other novice rendering users have the same issue. The Decals dialog and the Displacement dialog have a place to input an image, but the texture mapping dialog box doesn’t, and it’s weird to me.

These wishes apply to other kinds of mapping, too, in some cases.

unless you apply mapping, there is no mapping widget to display, so this behavior is as designed. I agree that the message may need to be clearer for 1st time users, but it seems that as soon as you do it once, the issue is moot. Is that the best answer, probably not, but for now that’s what we have to work with.

in regards to your displacement, there are a few things to unpack there…

  1. make sure your mesh is dense enough to displace correctly. In most cases you will need to use a custom mesh setting for your objects, and depending on your level of desired detail, will likely will need to add considerable density to get the displacement to look correct. see below-

  2. Then you’ll need to make sure your displacement density is set to an appropriate settings, i’d assume for reasonable detail, you’ll need to crank up your mesh memory limit tp something like 1000 to 2400. (try the defaults 1st, but if it runs out of memory, this is what you adjust to fix it)

Thanks, I’ll pull this up next time I do some displacement & see how it works out.

it’s a bit fussy because displacement has a few components, the most important is the render mesh… you need to have enough polys to actually create the displacement…then you have the image itself and it need to have enough rez and be blended well enough to have smooth edges, then you need to set the displacement initial quality to something that gives good results, and then add more memory to the process if it runs out… BUT…if you are willing to jump through all those hoops, you can extract the render mesh and then use it as a real mesh and print it, but I believe you already know that.

1 Like