Displacement is not working pèroperly in cycles rhino 7

Hello everyone,
the displacement map in rhino 7 cycles is not working as expected, the maps were downloaded from www.cgbookcase.com and imported into the physically based material properly through the “map autoupload” button of the material editor.
when I change the displacement height value in the material editor the preview is correct but when applied on the plane it’s not. The plane only shifts along the Z axis without differentiating the height point by point but keeping the overall planarity as if the mesh was not subdivided at al.
Is there an option to activate to make the planes behaving as expected with displacement maps?
see the attached images for reference.

maybe the plane is just an extrusion object instead a normal surface?

When you apply to a plane you’ll have to make sure the render mesh for it is very dense. Otherwise there’s only 4 vertices that are getting displaced, resulting in what you see.

no custom render mesh

Tweaking the render mesh settings on the plane:


And a bit more extreme displacement (:


1 Like

I see, thank you very much indeed!

And for fun bumped density all the way to 3 million polygons:


Hi Nathan.
The granite looks very good.
what would be the mesh setting for the “all the way” density

thanks a lot

Settings as above, but with maximum edge length set to 0.05. What you need to pick for your use case depends on your model unit settings and the size of your surface. This one is mm and roughly 90mmx90mm plane.

1 Like

Hi Nathan,

What happened to the surface of the sphere in this one?


Oh, I just increased a tiny bit roughness, and added a bump texture (:

Thanks, glad to hear it was deliberate and not a side effect of increasing the mesh density!