Displacement AND bumpmap - bump not showing


#1

I try to use both displacement for the bigger waves and bump for ripples. I can not seam to get a nice result in raytracing this. I have tried a lot of different settings and maps without luck. As you can see in the renders no ripples are showing, only displacement


(Nathan 'jesterKing' Letwory) #2

Are you able to reproduce with a simple scene? I.e. just a plane with displacement and bump map? What are you rendering with?

/Nathan


#3

Sure will do, tomorrow… now into bed. This is cycles native Rhino raytraced with 2000 samples using nvidia geoforce 950m


(Nathan 'jesterKing' Letwory) #4

Also heading to bed here. I’ll see tomorrow what is going on. If you can send a sample of where it goes wrong to me to nathan@mcneel.com that d be useful in setting where it goes wrong :slight_smile:
Good night, and thanks.

/Nathan


#5

Attached is a scene. Bump shows in rendered view but not in raytraced
waterscene Roy Berntsen.3dm (3.9 MB)


(Nathan 'jesterKing' Letwory) #6

For bumps to show well enough with Raytraced you should ensure your surfaces get meshed dense enough. For instance, if you set the displace to use High initial quality, you’ll see the bumps better too. This is an unfortunately side-effect of how bump can work with huge faces, like the ones you get with displacement turned off for your surface (for fun extract the render mesh - ExtractRenderMesh - and observe how big faces there are without displacement in use. Compare with an extracted render mesh after you’ve enabled displacement and set to high initial quality.)

I hope that helps you in using Raytraced.

/Nathan


#7

It seems to me that bump disappears when adding a transparency map when raytraycing. Se attached rendersamples - left is rendered view, right is raytracing

Edit - the opaque area below the hull section is also lost

with t map


no t map


#8

Here is the transparency image


(Nathan 'jesterKing' Letwory) #9

Looks like a victim of:

https://mcneel.myjetbrains.com/youtrack/issue/RH-37339

/Nathan