Disabling smart track points


#1

Hi

Disabling smart track points by double-tapping the cmd key doesn’t work if the cursor is over a smart track point - or between two smart track points (the grey lines appear). Double-tapping ctrl in the windows version (usually) works.
@dan

Philip


(Pascal Golay) #2

Hi Philiip - thanks, I’ll check this.

@Philip - as far as I can see this works here in my simple test. Does it ever work for you, or only sometimes?

-Pascal


#3

Hmmm, your reply made me test some more… It actually seems to work in a parallel projection viewport, but not so good in a perspective viewport (when a tracking line is ‘active’) - fails always here. Do you see this?

Philip


(Pascal Golay) #4

Hi Philip - so far, still good here in Perspective views. Shout if you can think of anything else to try - and, does it not work correctly for you in a new, blank file, using say, the Polyline command? That is my simple test so far - if you have more specific conditions, let me know…

thanks,

-Pascal


#5

Hi Pascal

Thanks for checking. I have to remember to do some more tests when I get home. No Mac here at work…

Philip


#6

Ok, back home testing on my Mac… The perspective view thing was false alarm - it happens in all views. I can get the unwanted behaviour if I start, for instance, the line command (or distance - or whatever) and just activating smart track points by moving my mouse around and hitting osnap points (usually by mistake when modelling) - and doing it WITHOUT CLICKING. In that case I can’t disable the smart track points by double-tapping cmd. Double-tapping the cmd key seems to be working normally if i go ahead and SELECT the first point in the command.
Any luck now? :slight_smile:

Philip


(Pascal Golay) #7

Hi Philip - I’ll check it, thanks.

Nope, darn; Cmd-Cmd to remove existing smart points still just works for me, so far regardless of the context.

-Pascal


#8

Ok, thanks for testing anyway! I wonder what’s wrong with my Mac…

Philip


#9

Hi @Philip
Disabling smart points by double-tapping the cmd key works perfectly on my iMac. Maybe some conflict and keyboard shortcuts or pointing systems?

Simon


#10

Thanks Simon! I really don’t know what the problem might be. I have no ‘unusual’ shortcuts or anything - and the problem is 100 % repeatable on my Mac - with the conditions I mentioned above.

Philip


#11

maybe your keyboard hooks up, dirddy for instance. try show keyboard overview in the language preferences of your system, which indicates each pressed button and tap the key several times, if it does not show each time you press its the keyboard.


#12

Ok, thanks! I’ll check when I get home.

Philip