Disabling scroll/pan during selection

Hi,

Is there a way to disable auto-scroll/pan during a box selection ?

Regards.

Hello - so far, I do not see any way to disable this.

-Pascal

Technically in Rhino 7 you can “lock” the view from the viewport menu, so the viewport can’t be changed.
The funny part is that the box selection in that case keeps moving as if the view was being scrolled, but the view stays put. @Pascal- this may be considered a bug in box selection with the new ‘locking view’ behavior introduced. If not for this, the above problem could be solved by locking the view.

–jarek

Hm - I see that, thanks. That is a little odd. But even when fixed, I am not sure this is really other than a makeshift solution for this request - I guess if users really need to turns this off there ought probably to be an ‘advanced’ setting for it.
RH-62206 Selection: Panning locked views
RH-62213 Selection: Disable auto pan
-Pascal

1 Like

My wish for Rhino 6 and later :
image

In my point of view, using locks is a relevant tool but has nothing to do with selection.

Regards

Hi Lahos,

To be clear, I was not referring to locking objects.
In Rhino 7 there is a new viewport feature where user can lock the view so it can’t be manipulated, or auto-scrolled for that matter. It might have been a good workaround if it did not act funny as described above. Maybe it gets fixed, otherwise an option to enable auto-pan is a good suggestion.
You could have a key shortcut to lock/unlock the view using the new _-LockViewport command.
It is also on the View menu here:

RH-62206 is fixed in the latest Rhino 7 Service Release Candidate

Still sad to manage every views one by one to disable scrolling during selection.

Regards.

Looks like there is a solution available now, via a test command. I did not try it but Pascal and Mikko posted this:
https://mcneel.myjetbrains.com/youtrack/issue/RH-62213

Magnifico !

I Hope the leading “Test” of the command TestAutoPan does not mean it may disappear…

Thanks

Hi,

Apparently it is discarded in the last release. So I’m back to the beginning.
Is there a way to disable auto-panning ?
I tried to set Rhino.Options.View.PanIncrement to zero but nothing changed.

Help ?!?

Regards.