Disable Seam Snapping


under Rhino Options > Modelling Aids, I can see some options to enable or disable certain snapping behaviour. I had hoped to find an option to disable surface seam snapping. Is this currently possible?

I’m working on a complex geometry of several pipes where I need to reliably snap to their centreline. Their rod diameter is quite small, so from a distance it happens way too easily that you snap to their seam, and not the adjacent centreline curve.

Even if you hide seams under Display, the snapping continues.

Would be much appreciated if there was a way. If anything, thank you for considering to add an option to said options menu called “Snap to surface seams — yes/no”.


Deselect Near in the osnap menu.

Hi @DuncanW
I would just Lock the pipe (and any other objects you want to avoid)and then disable SnapToLocked, so that snap only reacts to unlocked geometry.
HTH, Jakob

Hi Duncan - if the centerline is a curve, then disabling surface and polysurface selection filters should help with the snapping as well.