Disable click/pick and drag


#1

Hey, has any one figured out a way to disable the click and drag function. I am aware of the ability to set it to only drag selected objects, but I don’t find that always helps. For example when you are trying to select some object using a selection box and there are objects behind the ones you want to select. the first click simply selects the object behind, and the selection box does not appear. I find the click to drag function really annoying and not useful to anyone other than people doing artistic/conceptual models, who are not moving objects a very particular distance in a very particular direction.


(Wim Dekeyser) #2

You can set the drag threshold to some large number to prevent dragging. Mine is at 4000 pixels (and 100 for control points).


(Pascal Golay) #3

Hi Zander - holding Alt to make a Window selection forces ‘window-only’ behavior and the first click will not select. You can also type W and Enter to force a window selection (default alias for SelWindow).

-Pascal


(Miguel Villegas Ballesta) #4

So there is NO WAY to completely disable de function? Just workarounds?


#5

Yep, that’s it… I remember having heated discussions about this as early as Rhino 1.1 or 2. There’s always been a wall of resistance to having the option of disabling dragging completely.

–Mitch