DirectShape places SubD on wrong level

Although the preview in Revit space is correct, the SubD in the middle is placed on the bottom (underground) Revit level when using Add Geometry DirectShape component. The same does not happen for a Brep. Sometimes, Breps converted from subD also work, but some don’t.

What could cause this?

Could you please share the rvt file and the 3dm file you are using here?


subd problem.3dm (14.0 MB) subd (4.3 KB) subd problem.rvt (18.3 MB)

As an alternative method, you can also use families instead of DirectShapes; the same error does not appear. Use the Rhino origin point for location.

As a side note, notice that I add a specific name in the Comments parameter of the final shape so that Revit shapes that came from Rhino/Grasshopper can be easily found and deleted after you restart Revit and need to update your geometry.