Ding sound on entering values in GH

I posted this before in the old forums, but want to ask again, since its still happening in Rhino 6 + GH1.0

Can we get an option to not have a ding sound play every time I enter a value in Grasshopper. Its super annoying.

Disabling sounds all together or just turning the volume down is not an option as I work with sound and the system sounds are there for a reason and are actually helpful to recognise an error state. There has to be a way for Grasshopper to not cause a system sound being played every time. Especially since its an error sound that plays.

Thanks!

1 Like

I’m not really sure how to disable it. It’s just the standard windows text boxes dinging behind my back.

I’ve logged it, but no guarantees… RH-48847

It’s not clear to me what the OP means by " I work with sound and the system sounds are there for a reason and are actually helpful to recognise an error state.", but there may be a solution to his problem by using the Sound Control Panel:

This little gem is shown by clicking “Sound Control Panel” in the Settings/System/Sound option. On my system I have sounds turned off, but it looks like it is possible to control at least some program events from individual applications. Doing this with GH might be a problem because GH doesn’t seem to have a normal EXE module, but there may still be a way to specify particular GH program events.

It is not clear to me how program events get into the Sound Control Panel’s list, but on my system there are a number programs in the list that are not part of Windows itself, so I know there is a way to do it.

(Sorry David, I didn’t mean to complicate your day.)

I was trying to say that simply disabling the sounds altogether or just turning off the speakers is not a viable solution.

I assumed that there would be easier control of the sound in the code for Rhino/Grasshopper, but it sounds like its a little more difficult to deliberately turn it off. But then again I can’t think of any other windows software where that is happening, even though lots of them have control boxes where you enter values, so something has to be different.

Where it does make sense to play a sound - at least as an option - would be once the solution has finished calculating. I saw a forum post about it, so somebody has got that to work it seems. So sounds are not bad in general, but I just don’t need an auditory confirmation that I have pressed Enter :wink:

I agree, the sound every time you enter a value in Grasshopper is slightly irritating. Especially as I associate that particular sound with an error. If I recall correctly, SolidWorks used it to signify a rebuild error.

I’m just getting started with learning GH (again) so it hasn’t driven me mad yet, but imagine it might in time. I’ve already taken to clicking the green button instead, which doesn’t cause a sound.

Please can we have an option to turn it off.

Any news on this? I think this is what is happening: https://stackoverflow.com/questions/20506869/annoying-beep-when-i-hit-enter-in-a-textbox