Dims have lines through numbers

Hi, I have an odd problem where dims on line work drawn directly on the layout page are not masking the line they are associated with. Dims seem to work normally when snapped to geometry in a detail.

Any thoughts on this? I attached a screenshot of my pdf.

Thanks.


Hello- I do not see this here so far - can you please make a file with just a box, and add one of each dimension (one correct and one ugly) and post it here?
Please also run `SystemInfo1 in Rhino and copy/paste the results here.

-Pascal

Hi Pascal,

I did a test on a new Rhino file without any errors/issues. I could email the Rhino file that is acting up.

System info:
Rhino 7 SR13 2021-12-14 (Rhino 7, 7.13.21348.13001, Git hash:master @ 7696723f74a63695b3c372a89110c0ca8c78b890)
License type: Commercial, build 2021-12-14
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1650 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 10-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.47
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-18-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2021
Driver Version: 30.0.14.7247
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\Tim\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\AsaSimpleList (94937951-827c-4836-aba0-c2dc18afaf8b)\1.0.0.1\Rhino 7\AsaSimpleList.rhp “AsaSimpleList” 1.0.0.0
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\export_PDF.rhp “PDF Export” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”
C:\Users\Tim\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Hello- I would try this with these plug-ins disabled in Options > Plug-ins page (then close and restart Rhino)

Does that make any difference?

-Pascal

Another thing to try would be to select a good dim and an ugly one, then export them to a file.
Open the new file and verify the ugly one is still ugly, and post that file.

Thanks

Hi John,

I copied and pasted both dims to a new file with the same results. Can you explain the export process a little more? I selected the dims and exported selected as a rhino file but when I opened the new file there is not a layout page.

I attached a new Rhino file with the dims copy/pasted.
dim.3dm (6.0 MB)

I still have the same issues after disabling the plugins.

Hm - these look like this, here:

Not sure what is going on…
If you open this file in a new session of Rhino, with the plug-ins mentioned above blocked and not loading, you see the bad thing, correct?

-Pascal

Only on a pdf. They appear normal in Rhino.

Any difference when printing to PDF is you use Vector or Raster?

I’ll assume you are using RhinoPDF and not some other PDF authoring tool.

Does the print preview show the lines through the text?

So the plot thickens. When printing a pdf and setting the window extents the dims appear normal (raster and vector). When printing the full layout at 100% the problem persists (raster and vector).


test print vector zoom.pdf (154.0 KB)

Got it - thanks!
RH-66786 Print: Dimensions incorrect

-Pascal