Dimensions won't show up in any view?

Hi,

In the current version of Rhino 8 WIP (8.0.23045.12306, 2023-02-14) for macOS dimensions won’t show in the default views (e.g. Top, Left, Perspective, etc.).

I first first thought I had deleted them by accident or that their layer was turned off, but that’s not the case. The dimensions are also not hidden.

In the Layout view they show up.

Hi Marc -

If you start a new file and the first thing you do is create a dimension, I’m guess that shows up fine?
This sounds like the fall-out from the transition between the layer tristate to two different columns for layer visibility in model space versus paper space. In model space, when you scroll to the right in the layers panel, you will probably find a lightbulb that is off.
If that’s not it, please provide a simple 3dm and the SystemInfo from your machine.
-wim

1 Like

Yes, that works.

You’re right. The lightbulb in the hidden Model On column was off. Is that new?

Thanks, Wim!

@wim, this sounds like it will be a big source of problems unless you make the default appearance of the layers panel show the two columns. Once the user tumbles to what’s going on he/she can arrange the appearance as desired.

Hi Marc -

I’m not sure if I’m reading that correctly - in a factory-default installation of Rhino, all columns will be visible:
image

In a recent thread, a user had hidden that column manually:

… but we have not had any reports of situations where this has happened automatically.
-wim

Yes, I meant hidden by the narrow width of the entire right menu column. I had to scroll to the right to spot it, like you suggested.
Last week, this wasn’t present in Rhino 8, if I recall correctly. I had probably turned the concerned layer off, meaning the lightbulb which was among the first columns on the left of the layers palette, before saving and closing Rhino. In the new version, it seems like this translates to the lightbulb in the back column being turned off and the one in front being on, which caused the confusion for me.

Hi Marc -

In the previous public WIP, or the one before that, the single lightbulb had a tristate mode. If that file was originally created in Rhino 7, it’s possible that those states were set without you doing anything consciously. The tristate mode of the lightbulb was problematic and is now replaced by two different lightbulbs. If you often use Layouts and would like to be able to turn layers off in model space only, I would suggest moving the Model On column to sit next to the global On column.
-wim

1 Like

Yes, that’s the issue than. The file was indeed first created in Rhino 7, but I later migrated it to Rhino 8 WIP, because of the performance issues in version 7 running on Apple Silicon.

Got it! Thanks for kindly explaining this.

I honestly can’t remember ever needing a layer to be turned off in model view and on in layout view. I guess I’ll simply remove the Model On column or leave it at the back, since I’ll probably run into more situations like this in the future while revisiting older documents in Rhino 8.

1 Like