Dimensions are doing wierd things in Rhino 6... why?

Hi Peter!
I’ve had this one on my list and finally found that previous discussion - seems like we have crossed swords over this before :smile:

1 Like

Piping in, my alternate units should be scaling 6X and are not. This annotation style was originally created in R5. The weird multiplier is for a scale model reference. Tried changing alternate to Inches - Decimal but did not work. Also tried making a fresh annotation style but no dice.


Annotation settings below:

Hi Elijah,

That problem was reported above and the fix will go out in SR 6.9.

Thanks very much Alain

Guys, I’m having some trouble when opening a Rhino 4 or 5 archive in Rhino 6!
I’ve created a Layout, to Technical Drawings, in Rhino 4 and used it in Rhino 5, without any major problems, but when I open this Layout in Rhino 6, this (image below) happens… Any idea on how to solve this?

Hello - see if the settings here make a difference-


2 posts were split to a new topic: Dimensions disappear

Hello Pascal, thanks for the answer!

Yes, it made! The document I was having problems with is working now, with the Enable layout space scaling unselected.

There are some other documents that I was having some issues, I will try with them too


my dims are moving when I print to PDF, but oddly not when I print to the printer.

is there a known fix for this? Or am I being silly?


Hi - please run the Rhino SystemInfo command and post the result here. Also, please upload a simple sample 3dm file that shows the problem.

Hi @gileshg, what happens if you copy your whole drawing into a new empty file which is based on a default template included with the Rhino 6 install ? Does it still move the dims when you print to PDF ?


Hi @clement

I discovered that if I use print to Microsoft PDF then the results are good. That fixes the moving dims.

I was using an A3 layout from Rhino 6.

I still sometimes get odd faceted surface representation in shaded technical view sometimes.


Hi @gileshg, can you post an example file ?

This sounds to be a display related problem. If you run _SystemInfo, please post the results here.


Hi @clement

I can’t post system settings now. I don’t have rhino open. But this is a snap of the pdf.


Hi Giles - I’m afraid that this will be the minimum information that we need from you:


Hi @wim

here is my system info, sorry for the delay

Rhino 6 SR18 2019-9-23 (Rhino 6, 6.18.19266.14201, Git hash:master @ 3d84f88dec99b2f4e8b7497e739ed2adc2ba8ef6)
License type: Commercial, build 2019-09-23
License details: Cloud Zoo. In use by: Giles ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-87GA217

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 3-16-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 391.25

Secondary graphics devices.
Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-28-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-16-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Users\sales\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\RealDrawings (9aaa3b93-9ea4-4425-b44e-8a8c4500c274)\1.0.7038.31206\RealDrawings.rhp “RealDrawings” 1.0.7038.31206
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\sales\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2019.7.29.584\SectionTools.rhp “SectionTools”

@wim where could I send a 3dm file please? It has client details on it.



I have definitely seen this in the past, but it seems like it has gotten better. For me it wasn’t just dims, but all layout space objects. If I remember correctly, switching PDF readers helped with viewing, so you might want to try a few and see if you have better results. I currently use Foxit PhantomPDF.

For printing from the PDF to a printer, while it can look good in the PDF the print would be off similar to your example. I have to make sure Print as image is selected in my PDF viewer to not get this shift.

Hi Sam,

I ended up using print to Microsoft PDF and that works fine, so I stick to that, rather than Rhino PDF.



A post was split to a new topic: Moving detail and dimension breaks history in V6