Dimension scale 10times bigger

Does anyone know the reason why? Thank you

Check the length factor in the annotation styles length unit settings:

1 Like

Super. Is there an option to save all settings in a default/startup file (also my Environment in Render view is off by default) ?

Thank you @martinsiegrist

Save as Template…

And you can set the default to that file you just saved.