Dimension notes and bugs


#1

It seems that if when placing a dim, if I select Continue or Baseline, once I have completed the command, trying to run again does nothing. Closing and restarting Rhino gets it back.

Dims placed in layout space often fly off of what they were snapped to, often times on double clicking into a detail and back out again. I think this is history related. Is there anyway to turn off history for details to test?

With multiple details on a sheet, editing dimension text is really slow. With no details, it seems much more reasonable. Any change this could be improved? (let me know if you need an example file).

It seems when double clicking a dimension to edit it, I find myself activating a detail much more often then happened in V5. I think this is due to the control points popping on with the first click. If you select a dimension to see were the text position control point is, hover your cursor right over it, hit escape twice to turn of the control points, then double click without moving the mouse, it seems it will always fail to bring up the edit window, but will activate the detail.

Is there a more streamlined way to suppress a leading in 0 on something like 0¾"? Currently I have to override linear units from feet to inches, change linear format back to feet and inches (it automatically changes to decimal when changing to inches), then add " as a suffix. I can’t seem to find a way to access these overrides via the command line to make a macro. To be clear, if this question is having you think about changing how zero suppression currently works, I wouldn’t be interesting in 0 suppression when there is a foot component, such as 1’-0¾", just when the total dimension is less than 1".

Saving from V6 to V5, the dim text is converted from <> to the text of the dimension.

Thanks,
Sam


(Lowell Walmsley) #2

Sam - Thanks for the feedback.

I see the Continue problem in a public WIP build. I haven’t duplicated it yet on my local build, but I’ll work on that today.

For disabling history update, does it work to uncheck Update Children in the history menu from the status bar?
I may have to add something else if that doesn’t help.
“Fly off” sounds like probably the info about referencing detail coordinates gets lost somewhere and model space coordinates get used as paper space coordinates. I haven’t seen that lately, but I’ll see what I can find.

I’ll have to get back to you on the slow editing and double clicking after I mess around with it a little.

I think you can get to all that override stuff with python scripts, and I also think it would be good for me to make it work the way you like.

I’ll fix the v5 saving bug


(Lowell Walmsley) #3

@SamPage - I would like a file to be sure I’m seeing what you’re talking about.

Here are some bug reports from this:
https://mcneel.myjetbrains.com/youtrack/issue/RH-39577
https://mcneel.myjetbrains.com/youtrack/issue/RH-39569
https://mcneel.myjetbrains.com/youtrack/issue/RH-39574
Those are fixed pending testing

I’m not seeing the double click problem or the slow editing - Maybe I don’t have big enough drawings or something


#4

I uploaded a drawing via the file uploader. Let me know if that works for you.

Oh, I just saw your edit. I didn’t include instruction on the double click problem in the upload note. In the file on any sheet, but 20 is a good one, select a dim that is totally over a detail, hover your cursor directly over the text position control point, hit escape twice to turn off control points, then without moving your mouse, double click to edit the dim. Over here it will activate the detail.

Thanks,
Sam


(Lowell Walmsley) #5

@SamPage - I got your file. Thanks.
I still don’t see either the slow editing or double clicking problems
I’ll ask somebody else to take a look


#6

I’m also realizing didn’t send the display mode that those details use, so it might be opening on your end with the details in wireframe, which greatly improves the edit speed. Here is the display mode I was using, but I would imagine any shaded mode with shadows and wires would work as well.

Sam
Capture With Lines and Shadow.zip (2.3 KB)


(Lowell Walmsley) #7

@SamPage-
With that display mode I can barely get around at all.
I had to set the shadow memory way down to see anything.
I have a pretty small video card, but if I just open that file with your display mode installed, I can’t change to a detail in anywhere near a reasonable time.

I do see the very slow text update because of redrawing for every change.
I’ll see what we can figure out about that - it does need some attention

Once I got the shadow memory set way down so I could do anything, I haven’t seen a problem with double clicking.

I’ll find somebody with a bigger video card and see how it looks.

Thanks


(Brian Gillespie) #8

RH-39569, RH-39574, and RH-39577 are fixed in the latest WIP


#9

In the latest WIP, I can’t seem to find a way to retain that 0 inch unit; in the example above, I can only get 1’-¾". It would be nice to get that zero back for dimensions with a foot component.

Thanks,
Sam


#10

I’m also still having dimension save to V5 issues. Dims placed in layout space all seem to lose their length factor scale they get when snapping to objects in model space. So when saved down, dims will now show the layout space distance.

Dims with text added to them in V6 (so for instance <> TYP.) end up in V5 as something like {\rtf1\ansi\ansicpg1252\uc1\htmautsp\deff2{\fonttbl{\f0\fcharset0 Times New Roman;}{\f2\fcharset0 Arial;}}{\colortbl\red0\green0\blue0;\red255\green255\blue255;}\loch\hich\dbch\pard\plain\ltrpar\itap0{\lang1033\fs20\f2\cf0 \cf0\ql{\fs24\f2 {\ltrch <> TYP.}\li0\ri0\sa0\sb0\fi0\ql\par}
}
}

And easier for me to fix but still odd is that text orientation doesn’t seem to stick, at least when in V6 dimension text is set to Horizontal to view, in V5 that dim style will come in as Above dimension line instead of Horizontal to view.

Thanks,
Sam


(Pascal Golay) #11

Hi Sam - thanks, I’ll check these.
@SamPage - here it looks like zero-suppression is just not hooked up, is that what you are reporting? I confess it is not something I use, myself, but it looks like it is not working, to me.

-Pascal


#12

This all may be moot as I don’t yet have the latest WIP installed (trying to get a drawing package out today), but in last week’s WIP (6.0.17220.11131, 8/8/2017), the problem was actually too much suppression, not that it wasn’t hooked up yet. What I was seeing was a dimension that had a foot component and zero + some fraction of inches wouldn’t show the 0 inches. So I am getting 1’-¾" not 1’-0¾".

The only time I personally would want zero inch suppression is when the entire dimension is less than 1", so I would prefer ¾" to 0¾".

When I install the latest, I’ll see if I’m seeing the same thing.

Thanks,
Sam


(Lowell Walmsley) #13

You’ll get the same thing.
I thought I had that right a while ago, but it doesn’t look right now.
Maybe next week


(Dan Belcher) #14

RH-40833 and RH-40835 should be fixed in the latest WIP. Please give it a try.


(Lowell Walmsley) #15

@SamPage - This works now too: image


#16

Thanks Lowell!