Dimension lines: I cannot delete them

Hi everyone,

I created a dimension line, and now I don’t need it anymore. So I highlighted it and hit the Delete key, but it won’t go away.

How do I make the dimension lines and text disappear, please.

Thank you.

Stanley

Hi Stanley -
That sounds strange. Can you post a simple file that shows this behavior?
-wim

Thank you. How do I post the file, please?

Hi -

Simply drag-n-drop a file from Windows Explorer onto your message or use the upload button:
image
-wim

Exercise-106.3dm (183.1 KB)

Hello,
I try to open the attach file but I can’t do this.

No problem here.
I opened your file in Rhino V6, selected the existing dimension in the Top view and it turned yellow indicating it was selected.
Then I tapped the delete key on the keyboard.

Right. But when I tried to delete, it wouldn’t do so. Let me try again.

Same thing. I select it, and hit the delete key. But it won’t delete.

So I am experimenting more. Whenever I place a dimension line, I simply cannot delete. So I proceeded to place the dimension line in its own layer, and then I deleted that layer. And the dimension line would still not disappear.

That makes no sense.

If you type the SelDim command in that file, does it highlight? Can you delete it?

I suspect you have dodgy display drivers that are not properly changing the screen.
Please run the V6 SystemInfo command and post the results.

Thx

Hi John,

I ran the SelDim command, and the dimension lines did highlight. But I could not delete them.

Here are the results of the SystemInfo command:

Rhino 6 SR28 2020-6-23 (Rhino 6, 6.28.20175.14591, Git hash:master @ 9ddbd1399e001a3eae701470332b5379477fa7d6)
License type: Educational, build 2020-06-23
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-G2B3QE7

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 432.00

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version: 26.21.14.3200
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

this could sound silly but if you are using a laptop, the keyboard could be the problem. I mean in some cases the Delete key is associated with another function key, maybe the default is not Delete.
if that’s the case try pressing FN and the Delete key.

Hmm, is your delete key working for other things? If they are selected, does Ctrl+X remove them?

Your drivers are from 2019, I would update them in any case.

The delete key and Ctrl-X work for everything fine, except for dimension lines.

I will try to update the drivers, although doing so makes me nervous. So those are the display adapters, where it says NVIDIA GeForce RTX 2070, right?

Yes, your drivers are about a year old.
Current drivers for that card and Windows 10 are from late June:
https://www.nvidia.com/Download/driverResults.aspx/161303/en-us

John,

So, please, what is the best way of updating the drivers? Do I click on the link that you provided?

I am afraid of hurting my computer.

Stanley

Hi Stanley -
Please check if you have Lock Children checked under your Record History settings.
As dimensions are history-enabled by default, this setting will cause the behavior that you are describing.
-wim

4 Likes

Ahh, good catch Wim! Never thought of that - I can reproduce it here with lock children enabled.

Hi Wim and everyone,

That solved it. I unchecked Lock Children, and now I can delete the dimension lines.

Thank you so much. That was really troubling to me.

Stanley