Dimension command nightmare in V5... whats happened?


#1

Hi.

video attached, link later on…

V4
I use this method to create all my known dimension lines, and I create thousands.

Simple situation. horizontal line starting from somewhere on a vertical line.

to create a dimension of a known length along the horiz line from line’s end. (jnctn with vert line)

  1. click start of dimension at end of line (Int Osnap)
  2. enter length e.g. 100 and click on the line (Near OSnap) along which you want the dimension, end of dimension appears as a square 100mm along from the first click in 1.
  3. click anywhere on the line (NearOsnap) and a moveable dimension arrow at each end with 100 in middle appears, moveable up and down
  4. click on line (NearOsnap) to set its position on the line, (or click somewhere else to get extension lines to the line.)

result a dimension arrow at each end for 100 sitting along the line starting at line end.

V5

  1. click start of dimension at end of line (Int Osnap)
  2. enter length e.g. 100 and click on the line along which you want the dimension, end of dimension appears as a square
  3. click anywhere on the line (Near Osnap) and the end of the dimension changes to where you clicked, we now have 61.34 instead of 100…oh dear
    the rest of the process is lost as we now dont have 100

More often than not I dont even get that but I get 0.00 as a vertical dimension at a position on the line where I clicked in stage 2.
Something drastic has changed and I cant place dimensions anymore.

I have to place loads of dims from datums and its taken me an half an hour and I managed 100mm but once !

Whats going on in V5 ?

see video http://www.screencast.com/t/YeKO2evOBB where I type in 100 each time and hit enter. Only in V4 does it work correctly.

starts with V4. Oddly enough in this test vid I didnt get the vertical 0,0 to occur.

Steve


(Pascal Golay) #2

Steve, this certainly seems broken to me- for now, when you hit the Near osnap, tap on the Tab key, don’t click, and then click. We’ll fix this- thanks for the heads up.

http://mcneel.myjetbrains.com/youtrack/issue/RH-27101
(not visible to the public, yet)

-Pascal


#3

Hi Pascal,
Near Osnap is just on, and has been on , so I dont go near it, so not sure what you mean hit the near osnap.

I think I will revert to V4 as I have loads of dims to do.

When will we know this is fixed ?

Steve


#4

Pascal is saying that the dimension length that is being shown in V5 video you posted is what you are picking with your mouse click when the near OSnap active, rather than the 100 you were looking for. To work around this, don’t make you second pick with an OSnap active (all the ones in the V5 video you had a near OSnap active). Instead, either pick using ortho to constrain the direction of the pick, or if you can’t get your pick via an ortho constraint, get the direction using an OSnap, but instead of left clicking, tap Tab to constrain the direction, then click when you don’t have an OSnap active.

Sam


(Pascal Golay) #5

Near will work to set the Tab direction constraint without losing the 100 units distance constraint, just don’t click on Near - that is what is buggy - click after the tab direction constraint is set. If the dimension is in an ortho direction, then of course Near is not necessary.

-Pascal


#6

Trouble is I need an Osnap active to pick on a line to get the dimension onto the line, and thats where it ends up making its distance to, that last pick. If I have the end of the line then end or int gets round the near buggy.

For a dimension at start of a line, I have end on, Near off, ortho on.
I pick end of line, then enter value and hit enter, then I have the dim at the correct length, but need near back on to pick the line to set dimension to the line, or I could leave near off and use end to set it to the line.

For a dimension part way along a line or where I need Near…I /we are stuffed…
I need Near on, ortho on
pick line, enter value and hit enter, get the value and a moveable up/down dim, need to select the line, need near ,and oh dear I have 0.00 or some other length.

Its an often, in my case extremely often , used tool,

I am so used to this working properly in V4, given what I have to do I just can’t land myself with two or three stabs at setting a dimension each time, I use Near Osnap for a lot for things, so to keep finding it off when I want it on, and on when I must tur it off will be a pain. I shall be back and forth to it turning it on and off all the time.

I shall have to revert to V4 until its fixed. and I had planned to make the V5 move for the next project phase,…blast !

Are we looking at a week or so, or a wait until V6 ? I cant be denied V5 after having only just come out of the starting grid.

When will we know the bug is fixed ?

Steve


(Pascal Golay) #7

Can you please do exactly what I suggested? One more time: when Near is on, and lit up along the line, DO NOT click. Just hit the Tab key - tap and release, don’t hold it - THEN click. Yes, it is a stupid workaround for using Near in this case, if indeed you really need Near.

-Pascal


#8

Hi Pascal,
It worked fine for starting at line end but acted up for starting somewhere along a line,
not sure why as doing it again this time works, maybe I held tab down, dont know, however once tab is tapped , then near can be used.

if indeed you really need Near.

without near, I cant get the resulting dimension with number and arrow tips to end up on the line, unless you know a way, but I also use Near to start the dimension on the line.

Thus stages are:-

  1. click part way along line (need Near Osnap for that)
  2. enter distance vale and hit enter
  3. with ortho on, tap TAB dimension no choice but to go along line
  4. click anywhere and the dimension with arrows appears
  5. need Near Osnap turned ON to pick the line and get dimension exactly ‘on’ the line
    it wont take up length of where this ‘pick’ is

Is this bug the sort of thing to be fixed in Rhino updates and is it likely the next one will solve this ?

Steve


(Willem Derks) #9

Hi Steve try this:

  1. click part way along line (need Near Osnap for that)

2) with ortho on, tap TAB dimension no choice but to go along line
3) enter distance and hit enter

  1. click anywhere to set the dimension offset from the line

Does that work?

-Willem


(Pascal Golay) #10

Hi Steve- this behavior, it turns out, is required to support History in dimensions, so it will not be ‘fixed’. The Tab workaround is it…

-Pascal


#11

Hi,
Pascal…oh well, at least it works, we just remember the new routine, below.
I take it that whilst we had both dimensions and history in V4, this was something that didnt work and now does.

Just wondered, is there an online tutorial like the Rhino training dvd I have for V4 and would it then get updated with this new method ? Obviously dvd’s folk have wont have such updates. I won’t be the only one to hit this problem, anyone placing a dimension on a line will.

What is the procedure for informing users of changes to methods etc.

An online methods bank where we can visit and see updates and changes such as this reflected in the tutotial might be best.

Willem, yes on Line pick or off line pick work here.

FINAL STEPS.

Placing dimensions in Rhino V5.

Thus stages are :-

  1. turn on Near, click part way along line or at start of line (End or Int Osnaps)

  2. enter distance value and hit enter

  3. with ORTHO on, and NEAR On, let cursor find the line BUT DON’T CLICK, just tap TAB, the dimension has no choice but to go along the line

  4. click anywhere and the dimension with arrows appears

  5. with NEAR Osnap still ‘on’, pick the line and get dimension exactly ‘on’ the line or pick away to get extension lines.

In V5 it wont take up the length of where this ‘pick’ is.

Steve