digitize_Faro.rhp error

Continuing the discussion from Rhino 6 SR9 Release Candidate Available:

Not sure if this is the same, but every time I start, I still get the following, even if I load protect everything using digitize_Faro.rhp:



Please disregard, after my latest attempt at repairing the installation for another issue, this no longer happens.


Could you enlarge on this, since I’m getting exactly the same dialog whenever I start SR9 RC4?
Did you just run repair even though it was for a different reason?

Replaces any missing, unmodified files the installer originally deployed.

OK, but I experienced this with RC 2 or 3 and it continues with RC4. Does this mean that the RC4 installer isn’t doing something it should, or is this issue just carryover from a previous installation that the current installer won’t fix because it thinks the file is OK?

I’ll run repair before I start it again, but I was just wondering.

Mine was resolved after installing (and repairing) SR9 release candidate. Repair can be found under Add or Remove programs in system settings, select Rhino, and click Modify, you should then see a repair option.


The issue is the plug-in has been removed from Rhino but Rhino’s saved expectation to load it has not.
This was not intended but Brian is aware of it.

I think it’s fixed as I don’t see that message anymore in my in-house V6 builds.

I’m still getting the message on my laptop which I just updated to
Version 6 SR9
(6.9.18261.20431, 9/18/2018)
I’ve never had the message on my desktop though which was updated 10 days ago.


I ran repair and it didn’t fix this issue. I still get the faro error loading message. It appears 4 times for about 10-15 seconds as attempting to load with “wait” cursor and then a final time reporting the error.

Ah, yes. The historically inadequately designed Rhino plugin management system arises once again to bite us in the …

Haven’t Window’s capabilities and the developer’s knowledge advanced enough to redesign this subsystem to make more sense and be more streamlined for the lowly end user?

Thanks, I’ve reopened this bug for 6.9:

There was a 6.9 RC that went out that caused all the plug-ins to load on startup once. I think that’s the source of this bug.

@AlW does this registry key exist on your computer?

No, but maybe I’m not looking in the right place (there’s no “plugins” directly under …\6.0…:

Edit; some additional searching and I found it in HKEY_LOCAL_MACHINE\Software\McNeel\Rhinoceros\6.0\Plug-ins…

We think (hope) this is finally fixed. RH-47815 is fixed in the latest Service Release Candidate

Appears to be solved for me by Version 6 SR9 (6.9.18268.11381, 9/25/2018) Commercial.

1 Like

I just upgraded from 5.0 commercial to 6.0 (edu license) and am seeing the “Update your plugins” on every launch. If I click on “check now” I’m taken a web page with this text. If you want, I can open a new issue on this.

Rhino 6 has detected the following plug-ins on your computer. Click each link to learn how to update to versions that are compatible with Rhino 6.

  • Faro Digitizer by Robert McNeel & Associates

Just to make sure - which SR of Rhino 6 did you install?

Version 6 SR10
(6.10.18311.20531, 11/7/2018)

@brian, I’m not sure what to make of this one. RH-48160 makes it so that the Faro plug-in should be ignored. Running UpdatePlugins doesn’t list the Faro plug-in here on my system.

@jet thanks for this report. I’ve reopened RH-48160 and will fix it in 6.11.