Detail view overlay seems possible but only by chance!

i have 2 different behaviours while creating detail views. in one instance the viewport above is transparent allowing me to see the detail below:

and in another instance its opaque.

i would have thought the latter is the default. how is this possible and how do i replicate it?
NB: Im using visualarq for my drawings and using grasshopper custom preview to display the text legend.

Hi -

I’m afraid it’s impossible to even begin trying to find an answer to that question when you don’t provide files that we can use to try and reproduce something. For starters, is VisualARQ a required component in this behavior?
-wim

hi Wim, just uploaded both files. it would be good to have visualarq running because the whole model is built on that. If it helps i can create a dummy model without using visualarq? area statement.gh (256.9 KB)

Rhino file here : https://drive.google.com/file/d/11ncfBgrBiH4jJT31WYSFYfm6fQSBYx_G/view?usp=sharing

Hi -

Yes, please. I’d almost go as far as to say that that is required.
Apart from that, the Google Drive link tells me that I don’t have access and the GH file also uses the Elefont plug-in that I don’t have.

Realistically, if you want us to look at this, you’ll have to create a simple example that shows the issue. I’m afraid that I currently don’t have the time to weed through something like this:


-wim

totally understandable @wim i wonder why the link didnt work but i will chop it down anyway into something thats quicker for you to investigate.

1 Like

hi @wim,
i stripped out everything. no more gh no more visualarq.see layout ‘isometric lines’
overlaying viewports is highy desirable but i would like to be able to know that its not just wierd behaviour and that i can chose to control it.
I would then want to have 1 viewport with shadows and overlay a viewport with a gh preview running :smiley: (maybe a make2d script!)
RhinoCrashDump.3dm (6.5 MB)

Hi Aditya -
So far, so good. But what is the question now?
image
-wim

the question is how do i toggle between it having a transparent background and an opaque background? i had different(opaque) results on other layouts and this transparent one seemed like a fluke.

Hi @wim
thanks for looking into this.
im able to manipulate both viewports (with a little bit of drag when using shadows or ambient occlusion but thats understandable)
Im trying to figure out the best way to match viewports especially in different projections- im excited with the possibility of having a ‘live’ make2d running that i can overlay onto a shaded/rendered viewport.

Hi Aditya -
I’m still not very sure what you are asking.

What is the “it” in this sentence? There are 2 details and one group of curves on that layout.

If they are in different projections, they will never match.

It sounds like they easy way here is to add rendering of edges in your shaded/rendered viewport.
Putting two details on top of each other with both having the same (named) view but different display modes could work but you’ll have to play with BringToFront and SendToBack to get the result that you are after (if that’s what you are after).
-wim

apologies for not being clear wim. I hope this post is more understandable.

Indeed this is what im after.

the content in the detail appearing to have a transparent background and opaque background. In some instances the detail that was on top was opaque and cut out the detail below.
image
image
and in some cases appeared transparent. this is what I am trying to understand. Is this a property of the display style in that detail?

bummer :frowning: maybe if i can dig a bit and find out how to display grasshopper preview in paperspace? someone in a related thread said something about writing a custom conduit(although this is not something i have the knowledge to implement yet) if not no biggie.

Hi -

How are you defining “on top” and “below” here? Did you use BringToFront and such commands?

It probably isn’t but I suppose that it could be. It depends on what is in those details and the settings in the display modes but you haven’t supplied anything that looks like those pictures. And overlaying a Make2D result over a rendered viewport isn’t what you are showing anywhere. So I’m still not understanding what you are trying to achieve.

In that other thread that you refer to, the code for a conduit was given. It doesn’t look like there is any other way of achieving this.
-wim

yes exactly. I am using bringtofront/sendtoback to change the draw order.

I have now used the standard rhino display styles as you can see in the image below. the backgfround is in ‘arctic’. the overlay (left) is in ‘rendered’ and overlay on the right is in ‘pen’.


The background of both the overlays is transparent in this case which is great, however i had an instance where the background was not transparent. I am unable to replicate it except for when i activate the detail as shown below. I am trying to figure out whether its possible to do that without activating that detail-especially at the time of printing.

The make2D grasshopper overlay seems to require writing a conduit as you said, I will have to learn how to do that first :slight_smile: The only way i can do it now is it by pasting the make2D lines into the viewport- which you can see in the 2nd Layout which isnt a bad option.
im trying to acheive combinations of display styles so that I can create presentation packs and drawings within rhino without the added step of photoshop and indesign :smiley:
And thank you for your patience with all of my questions.RhinoCrashDump.3dm (9.1 MB)

Hi Aditya -

That is possible, yes. You can create a new display mode in which you turn the GroundPlane ON, and uncheck the Shadow only option:

image
That will give you something like this:


The detail with the white background is not active and is in the display mode that forces a background. It looks at the Make2D curves of the polysurface.
HTH,
-wim