Denoiser issue

It is fixed, but now there is another problem:

Let Cycles finish.
Now check Intel Denoiser and wait for finished.
Uncheck Intel Denoiser.
Original image is seen in the viewport.
Now check Intel Denoiser again.
Works.
Uncheck Intel Denoiser.
Check AMD or NVidia Denoiser.
Strange result with AMD.
No result with NVidia.

Nathan, you have a pretty similar hardware like me, so you should see this as well.
Or?

EDIT:
I tried to record a video.
Once I checked Intel Denoiser Rhino died and vanished.

@Charles the denoisers are done by @DavidEranen. They are completely separate from Cycles.

Ah ok, but the result is the same for me :slight_smile:
In any case, something is wrong.
Thanks Nathan.

@Charles understood. But that is why I @-mentioned @DavidEranen so he gets notified.

There is a bug report about crashing when repeatedly toggling intel denoiser. I believe @DavidEranen is close to releasing new denoiser plug-ins to fix the crashing bug.

Hi @Charles,

There should be a new version of the Intel Denoiser available now (v0.6.0). Please download the latest BETA before updating.

-David

Done:

On the first start after _PacketManager, only AMD Denoiser was there.
Shutdown - restart
Intel is there.
But doesn’t work at all (screenshot after 20 sec waiting):
image


AMD doesn’t work either (this is an AMD PC):


And NVidia isn’t there…
Shutdown - restart
Aha, NVidia is there.
I think this is an issue with the package manager.
OK, but NVidia doesn’t work:
image


Can you retrace that?
BETA
(7.0.20280.13133, 06.10.2020)

I believe the package manager only activates one plug-in each Rhino start, even if you installed many in one go. @will is the person who knows best.

Personally I think it should not be necessary to even restart Rhino in most cases…

@Charles I will try to reproduce the denoiser-loading issues. I am also updating the AMD and NVIDIA denoisers at the moment.

What AMD GPU do you have?

I thought the AMD Denoiser works on the _C_PU.
I could swear it worked before the updates!

The GPU in the PC is NVidia RTX 2070.


I think the other denoisers do work, but they don’t show the results in the viewport.
Just a guess.

If that’s the case then it’s a bug that needs to be fixed!

@will I wasn’t able to reproduce that particular issue. I was able to install them all at once and after restart they all loaded.

1 Like

Still the same with recent versions of Rhino and denoisers.

Have you made sure you are on the latest versions of the plug-ins?

Sure…

Ok, just checking. You said recent, not latest (: Anyway, the denoisers show their results in my v7 viewports. I tested all three (AMD, NVidia and Intel).

Any specific steps other than having a scene rendering and toggling the denoisers?

:smile:
image

And no, just let it render and check a denoiser.
Sometimes, when I toggle the viewport, the result is seen.

Any news regarding the issue?
I installed the latest video driver from NVidia, and found it is not driver related.

Hi @Charles,

I can reproduce the issue so I created a YouTrack item: https://mcneel.myjetbrains.com/youtrack/issue/RH-61327

-David

RH-61327 and RH-61455 are fixed in the latest Rhino 7 Service Release Candidate