Delayed Zoom with Wheel

something which is bugging me for a long time on Rhino for Mac which i wanted to get out but never did due to being too lazy :smiley: is that when i use the wheel for scrolling that its kinda sluggish. if you watch the video and listen carefully just turn the volume up then you can hear how i finish scrolling but it still zooms while being a bit choppy equally, now choppy is ok because its translated from the mousewheel, but sluggish is not ok.

it is very distractive when working zooming quickly in and out to relocate the view focus and when i compare it with CMD and right button mouse which translates zooming instantaneously and without lags or slugs then i can see its certainly not my computer which is too slow. (just be aware that the video has a little lag so zooming with CMD is much faster usually not visible on the movie but believe me there is a big difference in real life. so the power would be there just not translated properly.

i know that mac rhino had some performance issues and paning was sometimes horrifying during the beta phase but that got thankfully a lot better over time. just mouse zoom somewhere i had the feeling was a huge amount better in the beginning at least its still better on pc rhino.

i know @dan does not use a mouse anymore :blush: but maybe somebody who has one can have a look at this… maybe something can still be done in future about that pls.

maybe most of you have up to date computer from the next generation and you dont feel it there but if the computer has to compensate the performance i think thats also not a good idea… so pls pls have a look. @BrianJ or @pascal not sure who uses a mac and a mouse with wheel.

Don’t have my Mac with me here, but I do use it with a Logitech M705. Scroll zooming is as quick as it is under Windows, no noticeable lag. This is a mid-2010 MBP that has an NVidia GeForce card in it (GT 9600?). I have upgraded the HD in it to an SSD (which makes it like a new machine).


1 Like

set the mouse to scale factor 0.65 for example and try again. then compare with CMD right click scroll, still no difference? and mouse should not make a difference, i tried that with 3 different mice. computer should also not be a problem because CMD and right mouse click gives me 100% speed.

Traveling now (no Mac), won’t be able to test until Monday… Maybe @pascal can try… --Mitch

i notice significant lag with a lot of mouse actions, move, rotate, drawing line, basically anything that provides user feedback. it almost makes Rhino on Mac unusable it’s so annoying.

i don’t notice it panning, zooming, rotating views though. just tried with my magic mouse and logitech mx.

Hi Richard - the MMB scroll goes in clicks - in your case .65 makes a big jump per click; the Cmd-right mouse drag is a smooth transition, it does not care about clicks or steps so it is a smooth transition. I’m not sure if that is what you’re asking about but that is what I see in your clip above - expected behavior…


nope, thats ok that it jumps and understandable, what i mean is that when i zoom with the mouse that it delays a little - i stop scrolling it still zooms. not talking about the steps… its just slower with the wheel.

OK, thanks, - no, I am not seeing that here. Do you have a large/hi res screen?


maybe its more visible on longer distances, on short distances its rather ok still not perfect but when i zoom in or out bigger distances it rather gets noticeable.

yes it is not super high res but 2560 x 1440 on an external monitor, but that should not matter as described because CMD and right click has super response on the same resolution every zoom direction gets translated instantaneously like glued to my mouse so sure not the performance.

@pascal i also noticed that this behaviour gets slightly better when i am actually not in the app meaning having the finder activated for example or an empty safari without windows, having the rhino window still open. but as soon as i activate rhino with cmd tab zooming gets more sluggish even though having the same window configuration, meaning active tools hidden anyway. but as i said its more noticeable when i zoom out with a long role on the wheel zooming a big junk in one go.

All Macs (iMacs and MacBooks) have “small” problems with Bluetooth. It is important to know that mechanical disks (USB 3.0 especially) create interference on the frequency of the Bluetooth (the pointer has slowdowns, jerky zoom). Interference vary depending on how many Bluetooth devices are in the vicinity of the Mac (including iPhone and iPad)
Because many people (I myself for about two months after 5 years of Wacom tablet)) using Logitech Mouse MX, I would advise to disable the mouse from Bluetooth preferences and use the USB module provided in the package with Unifying technology.
The difference is definitely visible.
Of course this is not true for everyone but it is worth a try …

some consideration:

i’ve wanted to throw my mx through the floor so many times. when it becomes unresponsive i have to turn bluetooth on and off.

and my magic mouse will not stay connected unless i use apple branded batteries. smh

haha guys, i stayed clear from that blue tooth stuff… i never felt connected. i mean not just literally :smile:

sounds like apple… maybe the currency of your batteries is not high enough or not stable enough and the mouse (or computer) decides to disconnect.

oh thank you! what a difference. night and day.

@pascal is there any solution any suggestion to this?

i also noticed recently when i use NewFloatingViewport and fullscreen it with the os x native fullscreen and hide all the active toolbars and the sidebars, having nothing else than the viewport and a model, it speeds up, almost no delay.

having the viewport touching the tools and the bars seems to slow it down i also noticed this on the normal viewport when i have a lot of tools out and the sidebars but the difference is not as strong as with the explained newfloatingviewport.

Hi RIchard - those details are good - thanks. I see here from the private comments that the bigger brains do not know what is going on - perhaps this will help.


hmm well i dont know how exactly the interface gets refreshed, without trying to dig deeper than i am allowed to know i assume that the whole interface gets refreshed in a frequency…

to narrow it down i can say that there is a big difference in those two following display methods.
the first one here has only the document bar displayed

the second one is from the mac os native fullscreen and its as fast as i would wish it to be. there is a very significant performance difference.

that only the document bar has fault in the slow performance is unlikely, i dont think that it can be so heavy, another idea would be that the none fullscreened windows have a shadow behind, and this might cause it. maybe it gets refreshed where it should not, i mean that the whole screen gets refreshed through the graphic card is clear but maybe there is something being reprocessed which should not.

i have no other clues for now but i really hope you get behind it… i mean if i get a new computer sooner or later i may not feel it so strong anymore, still this should be taken serious, i dont want the computer heating up more than needed.

thanks @pascal pls check it out with the big brains.

I’ve been flailing trying to reproduce this issue. Frankly, I don’t even think I know what to do to reproduce it. Rather than continue to flail, can someone in this topic please give me a set of simple, easy-to-follow steps to reproduce the problem? What’s the expected behavior? What’s the actual behavior?

will try once more, bear in mind that my computer is a little older and that on new ones this easily may not be noticeable at all, also a small screen or small viewport does not show this problem very noticeable. to reproduce maybe take a bigger screen on an older computer i have a 32 inch screen from Asus running with 2560 x 1440 px you can also use a 24 inch with 1920 something but its less noticeable there.

rest of my specs:

to the problem
no objects needed just the cplane or draw anything you like. now zoom in and out with the mousewheel on any viewport in 4 view fast and with a long stroke in one go, now compare with a maxed viewport in the same manner any performance difference? when i let go on the mouswheel it still keeps zooming for a short moment kinda laggy like it would work off every increment of my mouse. now compare with cmd and right click the performance is right on spot. if you notice the difference create a new floating viewport hide all active toolbars and fullscreen it with native os x fullscreen so that it creates a new space automatically. here the performance with the mouse wheel is again faster like on a smaller viewport, as noted only the application shadow is missing in this screen assuming that this may cause the issue.

i can remember that on the same computer a few years ago running a version 4 windows version it went blazingly fast, mac always felt slower, also in using copy commands which still seems slow compared to windows but thats another issue which i can elaborate in another thread.