Default Rendered View: Gloss Finish wrecks Transparency


#1

When an object has a ‘transparency’ texture and you apply a Gloss Finish to it, the transparent parts behave very oddly.

Far away from the ‘glossy reflection’ they are transparent.
The closer the surface gets to the ‘glossy reflection’ point, it the more OPAQUE it gets. (this is wrong)

The TRANSPARENT part should STAY TRANSPARENT, and should not gradient from transparent to opaque.

When I disable the COLOR map, then the DARK BAND goes away, so the gaps now transition from TRANSPARENT to OPAQUE WHITE. (this is still wrong)

In my example below, notice the spaces inside the metal Texture. At the far edge they are correctly transparent, but at the center of the highlight they are completely opaque and white!

Example image:

This is in the RENDERED view mode in Rhino SR9 (5.9.40609.20145, 06/09/2014).

Is this a known bug for transparent textures on objects?

Also, enabling the ‘Bump’ texture (actually a Normal map) gives very strange results! (I can zip the files and send them to you if you’d like to take a look).


#2

Well actually it’s not really ‘wrong,’ glass is transparent but still has specular highlights. To make the holes act like empty space you need a map in the specular channel too to turn off the highlights in the holes. I don’t know that there’s a way to do that with the basic material in the basic Rhino renderer, though.


#3

In the real world, this behavior is wrong. 100% transparent objects do not reflect light. They do not cast shadows. They are invisible.

Now if we are trying to emulate glass, then there should always be a little bit less than 100%.

I think we’ve gotten so used to 100% transparency meaning “100% like glass”, that we use the term incorrectly.

How about a toggle switch under ‘Glossy’ with a name like “Use Transparency Mapping”?

When the transparency map has 0,0,0 black, and it is 100% applied on this material, I expect it to actually be 100% transparent in all cases.


#4

good idea, I’ve been driven mad by this as well


#5

In the “real world” there’s no such thing as a “glossiness” channel, that setting represents the appearance of fake reflections of fake light sources. Also in the real world, computer graphics let you make objects that are 100% transparent and 100% reflective because the way rendering works one effect has nothing to do with the other, and in the real world you would use something other than the built-in Rhino renderer for all but the most primitive tasks. So…nope, the basic renderer doesn’t give you enough hooks to make this effect work. The only surprise is that you’re surprised.


#6

You are right Jim, I was expecting more from the ‘transparency’ map than what it can do.

Oddly enough, the RHINO DEFAULT RENDER ENGINE reflects light on completely transparent areas, but mixes it using ‘Screen’ or something, so that the objects on the other side are completely visible. NEON does the same thing (when set to Rhino Render).

The ‘Render Preview’ mixes it by BLOCKING what is beyond the transparent object.

I was able to obtain it in Neon (with Brazil) by using the ‘Spec Level’ map.

I’d like to get the same effect in RENDER PREVIEW (IE, ‘transparent’ parts not reflecting light via glossy or otherwise).

I think a mapping channel for glossy effect would be the best option,

Either that or a new channel that is ‘Displacement’ which means that BLACK makes that part of the surface completely invisible.


#7

Aha! The Environment map obeys the transparency map!

(with the strange side effect that the shadows seen through the invisible parts have the same color as the Environment map…)