Default open with Rhino, Bug?


#1

For some reason I can not make Rhino 5 the default for opening iges files. I’ve removed Rhino 4 as it would open as the default program and I still cant get this to work.

Win7 64 on SBS 2011

Just me? Thoughts?


(Pascal Golay) #2

Hi Ken- have you tried to manually associate iges to Rhino via Windows, is that what you mean? (Right click on an iges, choose OPen With > Choose default program…)

-Pascal


#3

Correct on your Left click iges file description.
Did that first, Mapped to C:\Program Files\Rhinoceros 5.0 (64-bit)\System\Rhino.exe, No luck.
When I had V4 on this machine (uninstalled yesterday) the default stayed with V4. Once removed and I manually tried to remapped RhinoV5 would not associate even when selected.


(Pascal Golay) #4

Hmm- yeah, I see- not working quite right here either- how about if you right-click > Properties on an iges file and change the Opens With setting there- that seems to work OK here.

-Pascal


#5

No luck either way.
Looked on another machine (new laptop, recient install) not connected to our SBS server just to see it it was server permissions related (Should not matter as I’m in the admin group on the sever) ? The laptop already has the correct association and was not a problem to change the default or add another program to the open option.

Just noted the laptop has not been recently updated, running V5 5.6.31003.3365.

Desktop in Question? V5 5.6.31009.15315


#$#@! DXF file association
(Pascal Golay) #6

Hi Ken- something of a shot in the dark but try, in the Windows control panel, running the V5 installer and choose repair…?

-Pascal


#7

Pascal
Resolved

HKEY_CLASSES_ROOT\Applications\Rhino.exe\shell\open\command
The string still had the “Beta” in the path name, Once corrected all is good.

No idea how or when this got changed but it did.


(Pascal Golay) #8

OK, good- thanks for the update.

-Pascal