Decimals not working in Box Edit

unhandled

#1

Last night I updated to the latest version of V6 and the decimals no longer work. All dimensions with decimals are rounded up or down to the nearest round number. If I want to draw a 0.6 mm circle and I enter the figure 0.3 in the command bar, the dimensions of circle drawn, as shown by Box Edit, is 1 mm. If I try to change this 1 mm circle in Box Edit and I enter a 0.6 mm dimension, after I press enter the circle does not change and remains 1 mm. Box edit does not display any decimals.
In Document Properties/Units, Display Precision is set to 1.00. I tried other options from the drop-down menu, but nothing changed. Is there any other setting change possible?
So, I cannot create anything that has dimensions with decimals. This makes it impossible to make any objects with precise dimensions. I am unable to edit the dimensions of already created objects. I did not have this problem yesterday, this only happened after the last update.


(Tim Hemmelman) #2

Hi RaduB,

Sorry about that. This was a bug accidentally introduced while hooking up fractional feet and inches. It is fixed now and will be in the next release candidate.

See https://mcneel.myjetbrains.com/youtrack/issue/RH-45209
and https://mcneel.myjetbrains.com/youtrack/issue/RH-42756

Tim


#3

Thanks for the explanation. Hopefully the update will be available soon.


(Jeremy) #4

Hi,

Could you clarify which version breaks the decimals and in which version it will be fixed again - I’d like to miss the broken one as I use boxedit a lot…

Thanks


#5

The version in which I came across this problem is 6.4.18093.10341, 03/04/2018


BoxEdit not working right
(Jeremy) #6

Thanks!


#7

I downloaded the latest release candidate and the decimals are back. Thanks!


#8

I’m having an issue with box edit, I can’t get multiple objects to go to a certain Z position when set to “transform objects individually”, they wont all go to the same Z location but rather just apply the increment to each of them, which is the same result as not having transforming them individually but as a group. I’m generally finding Box Edit in R6 slower than R5. Thanks in advance for your help.