Debugger Error(RuntimeCallableWrapper )


#1

Hello,

Lot’s of times when I’m trying to debug I get the following error while rhino is loading:

DisconnectedContext was detected
Message: De overgang naar COM-context 0x3e1988 voor deze RuntimeCallableWrapper is mislukt met de volgende fout: De verbindingen van het aangeroepen object met de clients zijn verbroken. (Uitzondering van HRESULT: 0x80010108 (RPC_E_DISCONNECTED)). Dit gebeurt normaal gesproken omdat de verbinding met de COM-context 0x3e1988 waarin deze RuntimeCallableWrapper is gemaakt, is verbroken, of omdat een ander proces wordt uitgevoerd. De interfaces uit de huidige COM-context ((COM-context 0x3e1860)) worden vrijgegeven. Dit kan leiden tot beschadigingen of gegevensverlies. Als u dit probleem wilt voorkomen, moet u ervoor zorgen dat alle COM-contexten/apartments/threads actief blijven en beschikbaar zijn voor contextovergangen tot de toepassing klaar is met de RuntimeCallableWrappers die COM-onderdelen in de wrappers vertegenwoordigen.

Sorry most of it is in Dutch but I hope someone knows a solution.

Cheers Jordy


(Dale Fugier) #2

Sorry, this isn’t very helpful. How can I repeat what you are seeing?


#3

Hmm it even occured when my plugin wasn’t even dragged and dropped yet. So it’s probably something with VS2010. I’ll post a screenshot when I’m programming again and it happens. But also sometimes happens while I’m debugging and it gets to rhino


#4

I don’t know how to repeat it. I just create a new project. Save project as and pres F5. Then this happens 9 of the 10 times


(Dale Fugier) #5

Your project’s debug target is a release version of Rhino, correct?


#6

Well I guess not because mine looks like:

How can I change this?

P.S. Debug64:


(Menno Deij - van Rijswijk) #7

It seems this old message is related

http://news2.mcneel.com/scripts/dnewsweb.exe?cmd=article&group=rhino.plug-ins&item=31799&utag=

The fix for the problem in that thread was:

You can probably
get it to shut up by going to Debug > Exceptions > Managed Debugging
Assistants and un-checking the ContextSwitchDeadlock item.


#8

I’ve unchecked DisconnectedContext and that seems to work :slight_smile: ContextSwitchDeadlock didnt work :wink: Thanks for sending me in the right direction.


(Menno Deij - van Rijswijk) #9

Graag gedaan :smile: