Dealing with big files in rhino

I have a file that is over 2 million kb and when I open the mesh layer of this model, my computer lags when moving and rotating. I was wondering what I need to do to my computer to make my model run more smoothly.

Hi Samuel - one thing that may help is to set your display mode (Display panel, near the bottom) to use BBox display- that will degrade the display to boxes when moving the view around. I’d also turn off mesh wires in the display mode if they are on- try that first and see if it helps at all.