Data conversion from curves to line failed

Hi, I have a file that I built once and worked fine before. Now I’m opening it to continue working on the model but I can’t generate the gh script. One of the components I was previously having trouble with but fixed is now telling me something else. It’s saying that data conversion from curves to line failed. I’m guessing this is an easy fix but I was also wondering why it happened if the file was working fine before. Thanks in advance.

The picture at the bottom is what I previously got and I’m now going to edit it a whole lot.

my model for the ferry terminal.3dm (1.1 MB)
hexagonal (21.2 KB)

Try this maybe?

1 Like


What are you trying to do with the CurvePull component? Did you intend to use that curve as a region for anchors?
hexagonal (36.2 KB)

You can fix your line problem like this:

And the boundary issue like this:

1 Like

Hey thanks for the quick reply. I tried to re-do the script with the original model and it worked. That’s why I deleted the post but I just want to create honeycomb panels with the spheres I’m using. Anyways I’ll use these solutions if I encounter similar problems. I didn’t know what the curvepull component did and still don’t understand it. I just followed a tutorial

Thanks a bunch

edit: wow, this creates the best honeycomb structure. I’d say almost perfect if some panels weren’t missing. How’d you get to manipulate the curve pull so that it doesn’t lean in one direction?

1 Like

What is the name of the last input here? ‘Curve’, then ‘end points’, then ‘line’ then??

This is delete Duplicate Lines from Kangaroo.