"Dancing text" in Annotation Options window!

Sounds like I’m being silly, but I don’t know what else to call this craziness :slight_smile:
Plus it takes a looooong time for the dropdown to be selectable - not shown in video b/c it literally takes about 15-20 secs.

This is inconsistent, BTW.

EDIT: I just had the “Length Units” open while also having the “Font” category open, trying to change the font on some annotation setting, and both my screens went full-on1980s hacker movie on me for about 3 seconds. Don’t have a video of it, unfortunately.

Rhino 7 SR13 2021-12-14 (Rhino 7, 7.13.21348.13001, Git hash:master @ 7696723f74a63695b3c372a89110c0ca8c78b890)
License type: Commercial, build 2021-12-14
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 1-28-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.65
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 1-28-2022 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 1-22-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-28-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.0\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows”
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\2.0.1\Substance.Win.rhp “SubstanceImporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Hi Alan -

I’m not seeing that happen here. If you manage to isolate what triggers this, please let us know.

Will do.
I can say that it’s specifically the “Length Units” dropdown.
There’s some combo of going to another dropdown, and then back again, which gets rid of the oddity. But it’s def “Length Units” that’s the culprit.

It looks like you’re running 2 monitors.
Are they set to the same DPI and resolution?

I am, indeed, tho one is set to Portrait mode.

As a test, see what happens if you try an extended Desktop.

I’ve heard rumors the developers are working on handling dual screens that are setup differently, better in V8.
Currently, Rhino does not handle this asymmetry very well.

1 Like

I would recommend updating to the latest service release as a start. I’m not sure if this issue has been fixed, but it would be good to eliminate that possibility.

Ah, yes, I also have a problem where I haven’t been able to get my “Enable Updates…” option to work. I think @brian had replied about it - maybe RegEdit - but got too busy to follow through.

In Windows Services application, is the McNeel Update Service running?

Yes, it’s running. I tried restarting it but no luck

I’ve had this problem on a Mac and deleted the PLIST to sort it.
I have not had this problem in Windows.

Hm. Should IO try something with PLIST.
And what is PLIST. :slight_smile:

It’s a Mac thing.
You’re running on Windows I believe.

You can always just download and install from our website. It’s the same thing as what check for updates uses

1 Like

Thx. Wld be good to fix though, as Rhino doesn’t tell me when there’s an update anymore