Cycles unavailable as Renderer in Rhino6

Hi there,
I’m new to Rhino so perhaps I’m missing something fairly obvious, but I’d like to use the cycles Render in Rhino, but that option is unavailable under the rendering pane for “Current Renderer” options.

My Rhino version is:
Version 6 SR6
(6.6.18177.16151, 6/26/2018)

Is the Rhino Render option actually just cycles under the hood?
Do I need a plugin to access cycles? I was reading that during the WIP builds that is how it was available. Do I need to enable a setting somewhere?

Thanks in advance

This is where I’m checking, and there is no cycles renderer available. I’ve read that the “Raytraced” option in the viewport is now Cycles, but I’d like to access other options such as Global Illumination.
Is this possible?


Cycles is available as the Raytraced viewport mode. The search function of this forum should yield more info regarding this. There is a test plug-in call rhino-render-next you can search for on the forum (and no doubt other users can help with pasting the relevant links into this thread)

Global illumination for Raytraced is controlled with the skylight.

Is there any plan to add illumination from emissive textures for GI?

Thanks, I’ll check out the plugin!

There isn’t a premade emissive material with texture input, but there is already

Further you can use Grasshopper together with GhShaderNodes to create custom shaders

Hi Nathan,

I was looking for something like “Skylight” in Rhino 6… but with no luck. Is it part of whatever plugin?

thanks, Tobias

It is on by default in new Rhino6 documents, as part of the environment. So if you want to update a V5 file then either reset the render settings (to update the environment to v6 style) or import a V5 file rather than open it.

Thanks Jørgen, I imported a V5 file and I now got 20+ “Basic environments”… wtf
The whole environment thing is rather unintuitive and the help file is of no help at all.

yeah… that happens all the time with materials but I haven’t seen it with environments. The whole v5 -> v6 thing is a bit wip still… Anyway, just run Purge and see if that helps. Or open the V5 file and reset the environment from the rendering tab.